Salesforce integration stopped for all forms after upgrading my account to Silver.

  • Profile Image
    jill.millermlg
    Asked on May 25, 2021 at 11:12 PM

    After upgrading to Silver (and all the headaches that caused), our forms integration with Salesforce stopped working. I have re-authenticated all forms using the process above, but they still do not integrate! I have issued a ticket but with no response. Average response time is laughable.



    This is a re-post of a comment on How to integrate JotForm with Salesforce

  • Profile Image
    Jed_C
    Answered on May 26, 2021 at 06:05 AM

    We apologize for the inconvenience.

    Upon checking your forms, it seems that you need to reauthenticate your connection with Salesforce. Can you please try that again try submitting a form, see if that sends the data now?

    1622023504_60ae1d50768f4_The Easiest Onl

  • Profile Image
    jill.millermlg
    Answered on May 26, 2021 at 11:22 AM
    As I said in my submission, I have already completed the Salesforce re-auth
    and it reverted back to invalid. Forms still do not write to Salesforce. I
    even supplied a screenshot showing this step having been taken then
    reverted with the same form! Screenshots attached again. Please fix this
    asap - we are close to completion with what has been a very difficult
    upgrade.
    Jill Miller
    MLG Attorneys at Law
    1622042552_60ae67b8d3ea9_Jotform-false S
    1622042553_60ae67b97572e_Jotform-false S
    ...
  • Profile Image
    Basil_A
    Answered on May 26, 2021 at 02:42 PM

    Hi,

    I have cloned your form and tested the clone of your with the salesforce and the integration appears to be working correctly.

    Please attempt to connect to salesforce again. When you reach the page below please select the option to remove the integration.

    1622054369_60ae95e1419bd_chrome_oOErbSqt

    After that re-integrate the form with Salesforce by selecting the option "Use another account" on the integration page.

    1622054504_60ae9668373fb_chrome_arafFTg7

    Please let us know if the issue still persists.

  • Profile Image
    jill.millermlg
    Answered on June 01, 2021 at 02:02 PM

    Unable to "use another account" as we only have one account under jill.miller@mlgaplc.com. Tried with breaking integration, then refresh, then reintegrate. This worked but this is a @#$% ton of work! It is also untenable to have to go back and map every form field in every form to fix this issue that you guys created by an incomplete migration of forms!

  • Profile Image
    Jed_C
    Answered on June 01, 2021 at 06:12 PM

    We apologize for the inconvenience.

    If you have set your account password to expire often in Salesforce, this will cause some integration issue as Jotform uses security token which is tied to your Salesforce password.

    Kindly check this link https://help.salesforce.com/articleView?id=000338935&mode=1&type=1 on how you can check and see if you have the password set to expire. If you do, please set it to never expire to avoid integration issues in the future.

  • Profile Image
    jill.millermlg
    Answered on June 01, 2021 at 07:04 PM

    We do not have expiring passwords. That was not the reason for the integration issue - it was due to an incomplete migration after a very messy upgrade. I am forced to go through mapping all the form fields for all our forms to get this back to pre-upgrade...

  • Profile Image
    Jed_C
    Answered on June 01, 2021 at 08:15 PM

    I have forwarded this to our backend team for further checking as I'm not sure if the integration is related to the account upgrade. We'll let you know once we have an update.