My entire form flashes quickly when the page first loads then compressed down to normal

  • Profile Image
    Swags
    Asked on June 23, 2011 at 03:35 PM

    I have my form set up so that depending on what the user selects from the first drop down box, another corresponding drop down box will appear and so on...

    Therefore, only one drop down box should be visiible at first.  It looks absolutely perfect in the jotform preview, but once I add it to my website, when the pages loads, the whole entire form (all the drop boxes that shouldn't be visible yet) appears for a second then goes away.  How do I fix this?

     

    Thank you!

  • Profile Image
    allanftd
    Answered on June 23, 2011 at 10:57 PM

    Hi Swags,

    May we ask for the URL where the form is embedded? I checked the form page itself and it looks really fantastic!

    I can say that this issue is more related to how fast your browser can translate the whole form. The form code is pretty long (multiple conditions) and consider that your browser reads each line from top down. Hence, it sometimes takes time for it to display the form correctly. This is largely dependent on the browser used and your internet connection, beyond JotForm's control. But it should not happen all the time to all users.

    Please let us know if you have any other questions or concerns. Thank you for using JotForm! 

    JOTFORM SUPPORT

  • Profile Image
    Swags
    Answered on June 24, 2011 at 12:53 PM

    Hi allanftd,

    My website is actually not published to the web yet.  I am still creating it but I have to ability to preview what I have done so far in a browser.  I have used both IE and Firefox when previewing and the flash happens in both.  I cannot vouch for how fast my internet connection is here at my work but I could guess that it isn't the fastest in the world.  Hopefully it will change once I publish it.

     

    Thanks!

  • Profile Image
    DanielGriffin
    Answered on June 24, 2011 at 02:26 PM

    Hi guys,

    Yes this is probably a connection issue.  If you are developing the page locally then any local content will load instantly, whereas the form must be pulled from the internet, so there will be a slight delay for that portion of the page.  Please do let us know if you still have a problem after publishing the page.

    Thanks,

    Daniel

  • Profile Image
    Swags
    Answered on August 01, 2011 at 11:14 AM

    my website is officially published and it is still doing the flashing problem.  It is not just on my computer, but it does this on others' computers as well.  Is this a solvable problem?

    http://www.theconcretetailor.com/stamped-concrete-selection-guide.html

  • Profile Image
    Swags
    Answered on August 01, 2011 at 12:26 PM

    I managed to fix the problem by using the "source code" under the embed code option rather then using the "source code" from the source code option that is just to the right of the embed code icon.

  • Profile Image
    DanielGriffin
    Answered on August 01, 2011 at 03:03 PM

    Hi Swags,

    Thanks for the update.  Yes, it's better to use the complete source rather than the script tag for this type of problem.  Good to know that you have solved the problem. 

    Thanks,

    Daniel