What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    The conditions of my form are not working as they should

    Asked by Drake LaDue on January 06, 2014 at 10:56 PM

    NEED This working asap in the middle of conditional formatting for a presentation tomorrow.

    Page URL:
    http://form.jotformpro.com/form/40058813908962

    next
  • Profile Image
    JotForm Support

    Answered by EltonCris on January 07, 2014 at 02:03 AM

    Hi,

    They worked fine on my end. Please clear your browsers cache and cookies and try it again. It should work normally as usual.

    Screencast: https://shots.jotform.com/elton/Screencast_15-01_07-01-2014.mp4

    Thanks!

  • Profile Image

    Answered by drakeladue on January 07, 2014 at 02:22 AM

    Got that working it was a piece of bad code we had placed the other day and forgot to take out. BUT we are having terrible issues with the conditions. We are attempting to hide fields based on our choices but sometimes it hides the other options but most of the time it does not! This has cost us an hour for one product please help.Gotta get hti s done this eve for meeting tomorrow please help!!!!! Also the javascript is jumping on the page we put it in. How do we set the top margin?
    Drake LaDueCEO/Owner
    919-257-3977drake@brand-x-mobile.com
    ---- On Tue, 07 Jan 2014 02:03:21 -0500 JotForm Support Forum<jotform@jotmails.com> wrote ----
    A new response has been received:

    Answered by EltonCris

    Hi,
    They worked fine on my end. Please clear your browsers cache and cookies and try it again. It should work normally as usual.
    Screencast: https://shots.jotform.com/elton/Screencast_15-01_07-01-2014.mp4
    Thanks!



    View this thread on JotForm Support Forum Unsubscribe



    ...
  • Profile Image

    Answered by drakeladue on January 07, 2014 at 02:26 AM
    BTW here is the link to where the form resides. click on the returns tab. were still designing the tab has a temp name
    Drake LaDueCEO/Owner
    919-257-3977drake@brand-x-mobile.com
    ---- On Tue, 07 Jan 2014 02:03:21 -0500 JotForm Support Forum<jotform@jotmails.com> wrote ----
    A new response has been received:

    Answered by EltonCris

    Hi,
    They worked fine on my end. Please clear your browsers cache and cookies and try it again. It should work normally as usual.
    Screencast: https://shots.jotform.com/elton/Screencast_15-01_07-01-2014.mp4
    Thanks!



    View this thread on JotForm Support Forum Unsubscribe



    ...
  • Profile Image

    Answered by drakeladue on January 07, 2014 at 02:27 AM
    Helps if I send you the link :) http://ocutech.myshopify.com/products/ocutech-ves-k-3x-4x
    Drake LaDueCEO/Owner
    919-257-3977drake@brand-x-mobile.com
    ---- On Tue, 07 Jan 2014 02:03:21 -0500 JotForm Support Forum<jotform@jotmails.com> wrote ----
    A new response has been received:

    Answered by EltonCris

    Hi,
    They worked fine on my end. Please clear your browsers cache and cookies and try it again. It should work normally as usual.
    Screencast: https://shots.jotform.com/elton/Screencast_15-01_07-01-2014.mp4
    Thanks!



    View this thread on JotForm Support Forum Unsubscribe



    ...
  • Profile Image
    JotForm Support

    Answered by EltonCris on January 07, 2014 at 03:59 AM

    Hi Drake,

    The form does not work properly on your page due to script conflict, this is also the reason why the form fields appears instead of hidden thru condition. The most efficient way to resolve conflict is to re-embed your form using iframe embed code. Since the form loads in and iframe container, it won't conflict anything on your page.

    Hope this resolves the problem.

    Regards!

  • Profile Image

    Answered by drakeladue on January 07, 2014 at 04:41 AM
    No thats not the case it doesn't work on Jotform
    Drake LaDueCEO/Owner
    919-257-3977drake@brand-x-mobile.com
    ---- On Tue, 07 Jan 2014 03:59:43 -0500 JotForm Support Forum<jotform@jotmails.com> wrote ----
    A new response has been received:

    Answered by EltonCris

    Hi Drake,
    The form does not work properly on your page due to script conflict, this is also the reason why the form fields appears instead of hidden thru condition. The most efficient way to resolved conflict is to re-embed your form using iframe embed code. Since the form loads in and iframe container, it won't conflict anything on your page.
    Hope this resolves the problem.
    Regards!



    View this thread on JotForm Support Forum Unsubscribe



    ...
  • Profile Image

    Answered by drakeladue on January 07, 2014 at 04:42 AM

    The conditions are working for some and not for others. If we keep forcing the issue it dissappears which tells us its on the jotform condition side nothing else
    Drake LaDueCEO/Owner
    919-257-3977drake@brand-x-mobile.com
    ---- On Tue, 07 Jan 2014 03:59:43 -0500 JotForm Support Forum<jotform@jotmails.com> wrote ----
    A new response has been received:

    Answered by EltonCris

    Hi Drake,
    The form does not work properly on your page due to script conflict, this is also the reason why the form fields appears instead of hidden thru condition. The most efficient way to resolved conflict is to re-embed your form using iframe embed code. Since the form loads in and iframe container, it won't conflict anything on your page.
    Hope this resolves the problem.
    Regards!



    View this thread on JotForm Support Forum Unsubscribe



    ...
  • Profile Image

    Answered by drakeladue on January 07, 2014 at 05:19 AM
    It actually works great by the way on the page
    Drake LaDueCEO/Owner
    919-257-3977drake@brand-x-mobile.com
    ---- On Tue, 07 Jan 2014 03:59:43 -0500 JotForm Support Forum <jotform@jotmails.com> wrote ----
    A new response has been received:

    Answered by EltonCris

    Hi Drake,
    The form does not work properly on your page due to script conflict, this is also the reason why the form fields appears instead of hidden thru condition. The most efficient way to resolved conflict is to re-embed your form using iframe embed code. Since the form loads in and iframe container, it won't conflict anything on your page.
    Hope this resolves the problem.
    Regards!



    View this thread on JotForm Support Forum Unsubscribe



    ...
  • Profile Image

    Answered by EliezerN on January 07, 2014 at 09:28 AM

    @Drake

    Thanks for updating us about this.

    After cloning the form and checking it I found that you have created one condition only and it is working fine:

    So, if you had more conditions to hide/show more fields, it is pissible they were deleted somehow and that's why the form is not working as it should. I would recommend you to follow the instructions of this guide to correctly create conditions to hide/show multiple fields at a time:

    How to Hide or Show Multiple Fields at Once Based On a Single Conditional Entry

    If you prefer you can even share with us the conditions you wish to create or the fields you need to hid/show so that we can help you to make your form works as you need.

    I hope this helps. Please inform us if you need further assistance with this.

    Thanks

  • Profile Image

    Answered by drakeladue on January 07, 2014 at 11:47 AM
    I am not quite sure what you are looking at but here is the form there are more than 20 conditions
    http://form.jotformpro.com/form/40055664703956
    Drake LaDueCEO/Owner
    919-257-3977drake@brand-x-mobile.com
    ---- On Tue, 07 Jan 2014 09:28:45 -0500 JotForm Support Forum<jotform@jotmails.com> wrote ----
    A new response has been received:

    Answered by EliezerN

    @Drake
    Thanks for updating us about this.
    After cloning the form and checking it I found that you have created one condition only and it is working fine:

    So, if you had more conditions to hide/show more fields, it is pissible they were deleted somehow and that's why the form is not working as it should. I would recommend you to follow the instructions of this guide to correctly create conditions to hide/show multiple fields at a time:
    How to Hide or Show Multiple Fields at Once Based On a Single Conditional Entry
    If you prefer you can even share with us the conditions you wish to create or the fields you need to hid/show so that we can help you to make your form works as you need.
    I hope this helps. Please inform us if you need further assistance with this.
    Thanks



    View this thread on JotForm Support Forum Unsubscribe



    ...
  • Profile Image
    JotForm Support

    Answered by ardy0689 on January 07, 2014 at 02:41 PM

    Thank you for giving us the correct form URL. After reviewing your form, I can only see 17 conditions at most  and not 20 or more. This is probably the reason why some conditions are not working as it seems that they had been deleted for some reason.

     

    I tested the remaining conditions ndividually to see how they perform. Unfortunately, I can see some conflicts in your condition. For example this illustration

    As you can see, these 2 conditions check the value of Lens Type. If it is filled it will show Bifocal Seq. Height and if it is empty it will hide. As a rule of the thumb, when you show something it will automatically hide it unless the conditions are true. So by hiding it again on Condition 4 it is being redundant and will usually breaks this condition check. You should delete Condition 4

    I also see some ordering issues that could affect the Condition behavior being erratic. For example, in this illustration:

    The condition for Patient Systems, is place at the very top of the form, however, the condition you placed is at the middle of the priority list. In some occasions this is fine. However, I experienced that the condition will run smoothly if you prioritize your conditions from the top to bottom matching it on the position of the field. There are other conditions that are already prioritized to the top but their fields are located at the middle of the form. You may drag and drop Condition 7 to the top to give it a higher priority during form load. Also Condition 8 which is related to Patient Systems if it is set to VES-K, you should drag it to the top as well just below Condition 7.

     

    There are other more conflicts which is between from repetitive hides/shows to ordering issues. I will work on this form and get back to you within the day once I finished fixing it.

    In the meantime, you mentioned that it was more than 20 conditions and I only saw 17 of them. Can you please tell us which conditions are missing? So that I include them as well. We will wait for your reply so that we can assist you immediately. Thank you