What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    My conditions do not work properly

    Asked by Gastenlijst on January 08, 2014 at 10:35 AM

    Hi!

    Can you check my form? (aanmelden boss gastenlijst)

    I've made some conditions, but they don't seem to work...

    Through prepoppulation with URL, I've prefilled the "+" field.

    This can be "geen", 1, 2, 3, 4 or 5.

    I would like to hide/show the fields name1, email1, name2, email2 etc, by formatting.

    If the "+" field is 1, then only show name1 and email1 (or hide name2, email2, name3, email3, name4, email4, name5 and email5)

    If the "+" field is 2 then only show name1, email1, name 2 and email2 (or hide name3, email3, name4, email4, name5 and email5)

    and so on for values 3,4 and 5.

    I've tried to use conditions for this, but it doesn't seem to work... can you help me out please?

     

    Thanks!

     

    name check thanks 3
  • Profile Image

    Answered by pinoytech on January 08, 2014 at 12:22 PM

    Hi,

    Here's the condition you need in your form in order to achieve that:

    You might like to take a look at this clone form: http://www.jotformpro.com/form/40075050958959

    If you need further assistance, please feel free to contact us again at anytime.

  • Profile Image

    Answered by Gastenlijst on January 09, 2014 at 05:18 AM
    Hi!Great! I did this and that part seems to work, but..... Now my uniqueness part does not work properly anymore... When I submit, I get an error... Can you check on that please?Thanks!
  • Profile Image

    Answered by EliezerN on January 09, 2014 at 09:18 AM

    Are you refering this error?

    That happens because you probably have setup some limits of submission in the Form Limits settings of the form so that users can submit the form just once. So, all you need to do  is to disabled that limitation.

    If you need further assistance with this last inquiry, please open a new thread as it is different from the original question of this thread.

    Thanks

     

  • Profile Image

    Answered by Gastenlijst on January 09, 2014 at 01:36 PM
    Yes, you are correct. I've set the submission limit of the form to the uniqueness of the field at the bottom of the form (has no label, but says boss referentienummer at the bottom). This is a prepopullated field that gets his unique number from the other form. I can see that this number is unique but I still get the error message.Please can you check what I did wrong?
  • Profile Image
    JotForm Support Manager

    Answered by Jeanette on January 09, 2014 at 04:17 PM

    You set Unique Submissions by limiting the number of submisisons or an Expiration Date, whatever reaches first would make the form to get disabled

    Please check for further details on this form

    https://www.jotform.com/help/137-How-to-Limit-Submissions-in-a-Form

     

    You can also setup a lmits based on a Unique Question,please check this guide

    How to set Form Limits Based on a Unique Question

  • Profile Image

    Answered by Gastenlijst on January 09, 2014 at 04:24 PM
    I have done exactly that, but it still doesnt work. Please can you check my form to see if I did anything wrong? I havent set submission limits or exp date, but unique question to the lower box (no label, but says boss reference). This is prepopulated with values from the other form and are unique.
  • Profile Image
    JotForm Support Manager

    Answered by Jeanette on January 09, 2014 at 06:42 PM

    The Unique Question was left as blank, but I've fixed this. I just sent a test and it works just fine

    Should you need further assistance, let us know

  • Profile Image

    Answered by Gastenlijst on January 10, 2014 at 05:42 AM

    Hi!

    No, the unique question was left blank because the field had no label.

    I've labeled the field : "BOSS" now. I've set unique question to that field.

    But it seems as if my conditions interfere with the unique question.

    I'm so sorry to ask for it again, but can you check ik for me again?

    When I set unique question to that field and use conditions, it doesn't seem to work...

  • Profile Image
    JotForm Support Manager

    Answered by Jeanette on January 10, 2014 at 10:35 AM

    I think the problem lies in the way you have set up the conditionals

    Also, for some reason, I was not able to type in field labeled as "+"   nor I could in the Boss field. So I've replaced these fields with new text boxes and renamed the "+" to " Do you want to add more?

    -I've set the Boss field as the Unique Quesion, and now it works

    -I've setup conditionals for when " Do you want to add more? " is filled with 1 or 2.

    Can you please check my clone?

    If this is right what you expect, let us know so we can help you to complete your form

     

     

     

     

  • Profile Image

    Answered by Gastenlijst on January 10, 2014 at 12:45 PM
    Hi! Thank you for your help, but that is not what I was looking for.Let me explain it to you: I use 2 forms. The first (aanvragen) is meant to make a unique ID, which is prepopulated in the other form through URL in the autoresponder. There are 3 fields that are prepopulated that are read-only fields, so they cannot be changed.The most important one is the BOSS field at the bottom, because this one has to be unique entry, so i've set this one as my unique question. This prevents that my url link will be used twice,Then the second thing is that I've added a "+" field for extra guests. This one is also prepopulated and read-only. The conditions that are set are based on de "+" field. Depending on wat is prepopulated in that field, the fields name1, email1, name2, email2 etc will be shown. (As discussed above)The problem: when I set conditions in combination with unique question, I get the error message as stated above. Without the conditions but with unique question it works and vice versa, but the two toghether seems to give problems..So now I would like to know what I did wrong in the settings. Hope you can help me with this!
  • Profile Image
    JotForm Support

    Answered by Mike_T on January 10, 2014 at 03:06 PM

    The problem: when I set conditions in combination with unique question, I get the error message as stated above.

    Can you please provide us with a screenshot of that condition?

    How to upload and add screenshots to support forum?

    Thank you.

  • Profile Image

    Answered by Gastenlijst on January 13, 2014 at 09:52 AM
  • Profile Image
    JotForm Support

    Answered by ardy0689 on January 13, 2014 at 10:57 AM

    Hello, I can see your first screenshot but your second screenshot seems to be not working. I tried to enable the "Condition" along with the "Unique Submission" altogether on my cloned form. However, during my test, I can not see any error and submitted successfully and has redirected to your thank you message

    You are probably, seeing this error because the "Unique Question" took effect. In my situation, I prepopulated the BOSS field with http://www.google.com. Now I submitted it the second time and I saw the same error above provided by my colleague.

     

    It seems that it is working fine as intended, all you need to do is to go to your Submissions page of the form and delete the test submissions you did. This will make the Unique Submissions feature take effect again.

     

    It does that because, the form sees that there are already entries with the same BOSS values. This is why you see the error. Deleting the submission will make it work again. Please try it and let us know if this issue is persisting. Thank you

  • Profile Image

    Answered by Gastenlijst on January 13, 2014 at 04:09 PM

    Hi!

    Thanks again so much for your help!

    It's still not working though... I've deleted all submissions and tried again.

    - first time request went fine, I've sent the request and the url in the responder email works perfectly! all emails were sent and request was submitted!

    - tried second time with the same url link in the responder email and it didn't work (this is correct! the link that is provided with the unique question in the BOSS field should not work twice!!) 

    Happy so far...

    - then  I went on and sent a second request and used a new url link in a new responder email. ------> here it goes wrong... even though there is a new unique question value in the BOSS field, the submission gave the error...

    eventhough this unique question value has not been used before...

    To be clear: the unique question value (BOSS field), is generated in the "aanvragen" form and then prepopulated in the BOSS field through URL in the responder email, this value is thus never the same, unless the same link in the responder mail is used twice.

    Can you help me out once again?

  • Profile Image
    JotForm Support

    Answered by Mike_T on January 13, 2014 at 06:16 PM

    I was able to reproduce the error. I am still testing this, so I will get back to you later today.

  • Profile Image
    JotForm Support

    Answered by Mike_T on January 13, 2014 at 08:11 PM

    It is probably that something is conflicting on the 'Aanmelden BOSS Gastenlijst' form. Please move the BOSS field to the top section of your form:

    It appears to be fixing the issues on my cloned versions of your form.

  • Profile Image

    Answered by Gastenlijst on January 14, 2014 at 07:58 AM

    Hi!

    Thank you. I moved te field to the top of the page. It now all seems to work.

    But...

    I need this field to be out of sight, or less in sight.

    Can you please help me do the following:

    - either hide this field

    - or make this field as small and unseen as possible. I know this can be done bij Custom CSS, but I don't know how. If you could instruct me or do it for me, I would be eternally grateful. Please make it the smallest fontsize you have and if possible make the font grey.

  • Profile Image

    Answered by Gastenlijst on January 14, 2014 at 09:51 AM

    never mind...I think I got it already!