My forms are being cut off on the bottom on multiple pages/website. Embed using iFrame

  • Profile Image
    aiapparel
    Asked on January 11, 2014 at 03:17 PM

    My forms are being cut off on the bottom on multiple pages/website. Embed using iFrame

    This only started happening. I am seeing this on my iPad as well as pc with Safari and Firefox 

     

    http://alternative-intelligence-wholesale.myshopify.com

    http://www.aiapparel.com/pages/contact 

  • Profile Image
    krispi
    Answered on January 11, 2014 at 04:29 PM

    Hello

     

    Please try to go to "setup and embed" > "Preferences" > "Form Styles" and then "Inject Custom CSS" and write:

    .form-line {
        padding-bottom6px; }

    This will probably solve it. All the best!
    C.
  • Profile Image
    Cesar
    Answered on January 11, 2014 at 06:51 PM

    You can also try increasing the height code of you iFrame code from the current 862px to 890px.

    890px</span></strong>; border: none;" scrolling="no">

    Example code used:
    https://cms.jotform.com/uploads/image_upload/image_upload/global/23270_jedihustler.png 

     

    If you need further assistance, do let us know. Thank you.

  • Profile Image
    aiapparel
    Answered on January 12, 2014 at 12:01 AM

    Thanks for the replies however neither fixed the problem.

  • Profile Image
    TitusN
    Answered on January 12, 2014 at 04:58 AM

    Hello, 

    Please increase your iframe embed code height to 890px following Ceasar's directions. 

    It appears it is still at 862px. 

    <iframe id="JotFormIFrame" onload="window.parent.scrollTo(0,0)" allowtransparency="true" src="//form.jotform.us/form/31460606644148" frameborder="0" style="width: 100%; height: 862px; border: none;" scrolling="no"></iframe>

    Getting a fresh embed code will also fix this. 

    Please let us know if this helps. 

     

  • Profile Image
    aiapparel
    Answered on January 12, 2014 at 04:16 PM

    I am showing the height below on my backend is 894px. This is what i copied from Jotform. The fresh code did not help as it was exactly the same

    height:894px;

    I have tried increasing it but had no success.

  • Profile Image
    jonathan
    Answered on January 12, 2014 at 05:27 PM

    @ aiapparel

    Hi, I checked your form on your website here http://wholesale.aiapparel.com/ and was also able to see the issue on the cut-off form.

    Can you please try re-embedding the form again using its iframe code BUT this time, exclude the script part of the code. The iframe code below is the full code generated for your form. Try to use only the code highlighted in yellow and exclude the lower script code highlighted in red.

    <iframe id="JotFormIFrame" onload="window.parent.scrollTo(0,0)" allowtransparency="true" src="//www.jotform.us/form/31460606644148" frameborder="0" style="width:100%; height:910px; border:none;" scrolling="no"></iframe>

    <script type="text/javascript">window.handleIFrameMessage = function(e) {var args = e.data.split(":");var iframe = document.getElementById("JotFormIFrame");if (!iframe)return;switch (args[0]) {case "scrollIntoView":iframe.scrollIntoView();break;case "setHeight":iframe.style.height = args[1] + "px";break;}};if (window.addEventListener) {window.addEventListener("message", handleIFrameMessage, false);} else if (window.attachEvent) {window.attachEvent("onmessage", handleIFrameMessage);}</script>

     

    Please try this method and check again if this make the difference.

    Inform us if issue persist.

    Thanks.

  • Profile Image
    EpicStudio
    Answered on November 05, 2014 at 03:51 PM

    Hi there. I have the same problem. I already tried an augment on the iframe style height tag, removing the <script></script> from the iframe code, and alsao adding a 100px padding; but from time to time, every other time you load my page http://grupoimaginarq.com/contacto/ the form seems to crop vertically. Gladly I allowed the scrolling to avoid losing the chance to use it, but certanly it's not the result I expected from it.

    Note: it only happens randomly when you load the page, and only on firefox.

    Thanks for your help.