The analytics page doesn't register the right amount of devices.

  • Profile Image
    fvhsurvey
    Asked on June 30, 2021 at 12:27 AM

    Dear Jotform

    In Form Analytics I saw a problem about statistics. In Response section, we may have a number ### of responses for that form. But in Device subsection we have a different number of responses. An example of that problem is described below

    1625027197_60dbf27d1a3d5_

    we have 29 responses but in device section we only have 11 responses for Generic tablet

    Could you explain for me? Thank you

  • Profile Image
    ashwin_d
    Answered on June 30, 2021 at 04:57 AM

    I am sorry for the trouble caused to you. Please let us know in which form's analytics page you are seeing this issue and also let us know the date range of the filter, we will take a look.

    We will wait for your response.

  • Profile Image
    fvhsurvey
    Answered on July 12, 2021 at 02:49 AM

    Dear ashwin,

    all the forms had that problems. For example, this following form

    https://www.jotform.com/analytics/210968651710457

    1626072357_60ebe5252a467_

    from 7/4/2021 to 12/7/2021 it had 15 responses but only 5 devices

    Or that form

    https://www.jotform.com/analytics/211042254860446

    1626072539_60ebe5db09804_

    from 15/4/2021 to 12/7/2021 it had 35 responses but only 11 devices

    Other forms also had that problem.

  • Profile Image
    Gaetan_B
    Answered on July 12, 2021 at 04:48 AM

    Hello,

    Thank you for the additional information.


    It seems indeed that it registers the traffic properly, but not the devices.

    I will ask our backend team to look into it and we'll revert back to you as soon as we have an update.


    Best regards