"Please wait" button displays indefinetely after the form is submitted.

  • Profile Image
    johngugel
    Asked on July 02, 2021 at 04:15 PM

    When the "submit" button on my form is activated it say "please wait" but nothing happens.

  • Profile Image
    Cecile_A
    Answered on July 02, 2021 at 10:50 PM

    Greetings,

    I cloned your form 211774087820155 to test but I was unable to replicate the issue.

    I have cleared your form cache. Could you please try clearing your browser's cache as well?

    If the issue persists, kindly let us know.

    Thank you.

  • Profile Image
    johngugel
    Answered on July 03, 2021 at 09:04 AM

    Thank you!

    Others have tried and are having the same issue with this particular form. I have sent test messages (not this form) from Jotform and have received them so I believe the email address is correct.


    John



  • Profile Image
    Igor_B
    Answered on July 03, 2021 at 12:26 PM

    Hi John,
    I have tested your form and unfortunately was not able to replicate this problem. Is your form embedded on a website?

    Sincere apologies for this inconvenience, we are doing our best to investigate this issue and help you solve it.


    Best,
    Igor

  • Profile Image
    johngugel
    Answered on July 03, 2021 at 12:55 PM
    Thanks, Igor!
    Yes, the form is embedded on our web site www.racquetquest.com
    Thank you for your help!
    Regards,
    John
    ...
  • Profile Image
    Igor_B
    Answered on July 03, 2021 at 02:27 PM

    Hi,

    I was able to reproduce the issue on your webpage. This is the error you are getting:

    1625336508_60e0aabc01b85_

    Please try adding allow-forms to your iframe element:

    1625336655_60e0ab4f08990_

    If you have used the script option to embed the form on your website, try switching to iframe code available in the Publish section of the form builder.

    I hope this will help you solve your issue.

    Best,

    Igor