HELP! I NEED TO LAUNCH!!

  • Profile Image
    telltheworldaboutus
    Asked on July 09, 2021 at 09:24 PM

    I have done everything according to this link: https://www.jotform.com/help/1024-how-to-integrate-authorize-net-with-jotform


    I watched this video:



    I have set it all up.


    I ran a test purchase using my debit card and this is what I got:


    NO SUCH LUCK: Error on transaction

    The 'AnetApi/xml/v1/schema/AnetApiSchema.xsd:invoiceNumber' element is invalid - The value 'RetailXtreme Marketing' is invalid according to its datatype 'String' - The actual length is greater than the MaxLength value.



    PLEASE HELP WE MUST LAUNCH THE COMPANY!!!

  • Profile Image
    Patrick_R
    Answered on July 10, 2021 at 01:27 AM

    Hi! Make sure that you have a working Authorize.net account that is ready for transactions. You can confirm this from Authorize.net support.

    After that, remove this widget from your form and then re-insert it. This will clear any caching issues that might be causing this problem.

    Then clear your form cache.

    After this, make a test submission on your form.

    In case this doesn't solve your problem, let us know.

    Thank you!

  • Profile Image
    telltheworldaboutus
    Answered on July 10, 2021 at 01:51 PM

    I did EVERYTHING you asked. TWICE.... and its still showing the SAME error message.


    I MUST LAUNCH ASAP... if I can't, Ill have to chose another plaform which is sad :(

    https://pci.jotform.com/submit/211025928118047


    Blessings....

  • Profile Image
    Patrick_R
    Answered on July 10, 2021 at 10:00 PM

    Hi there! I noticed that you removed the Authorize widget completely.

    Can you please put it back? We'll test a cloned version and get back to you accordingly.

    Thank you!