Hidden Field Not Populated to HREF Except Mailto

  • Profile Image
    antoniooi
    Asked on January 23, 2014 at 05:12 AM

    Hi JotForm Support,

    I noticed that the hidden field filled with valid URL is unable to populate the HREF attribute of an anchor except for anchor tag with"mailto:name@example.com" as shown below:

    <b>Email:</b> <a target="_blank" href="mailto:{tpemail26}">{tpemail26}</a>
    <br />
    <b>More Courses:</b> <a target="_blank" href="{tpprofileurl}" >Visit {tpname}'s Company Profile</a>

    Please check with your programmers. Thank you.

  • Profile Image
    ashwin_d
    Answered on January 23, 2014 at 06:46 AM

    Hello antoniooi,

    Upon checking, I found it to be working fine.

    I created a test form and added two hidden box which populates the anchor tag in auto responder email. Please take a look at this form: https://secure.jotformpro.com/form/40223226356951?

    Please use a valid email address in form and the auto responder email will have the correct anchor tag. Do check and get back to us if this works for you.

    Thank you!

  • Profile Image
    antoniooi
    Answered on January 23, 2014 at 07:37 AM

    Ashwin,

    I can't import your form to check your work. I received this error:

    No form found on the page. Please check the source code you provided

    Meanwhile, if you read my previous post again, I didn't say my mailto URL got problem; I said my hidden field with valid web URL cannot be populated into the HREF of my anchor tag. No problem for my mailto.

  • Profile Image
    antoniooi
    Answered on January 23, 2014 at 07:49 AM

    To make my explanation clearer, the below marked with RED is having problem:

    <b>More Courses:</b> <a target="_blank" href="{tpprofileurl}" >Visit {tpname}'s Company Profile</a>

  • Profile Image
    ashwin_d
    Answered on January 23, 2014 at 07:51 AM

    Hello antoniooi,

    Please try the following form URL to clone form: 

    http://www.jotformpro.com/form/40223226356951

    I believe the mailto and the href both works fine. Do check and let me know if the example in my form is exactly what you want.

    Thank you!

  • Profile Image
    antoniooi
    Answered on January 23, 2014 at 07:53 AM

    I don't understand why your forum editor always want to auto-insert to distort my message and to create further confusion.

  • Profile Image
    antoniooi
    Answered on January 23, 2014 at 08:11 AM

    When looking at your code, I saw you placed a forward slash (/) before the {url} variable. So are you trying to tell me that I need to put a "/" before my URL variable?

    Secondly, your hidden field value doesn't seem to be a FULL URL: www.jotform.com without http://. If I'm not interpreting wrongly, your actual URL could become:

    /www.jotform.com

    This is weird and not intuitive to promote learning. It's not a natural way for users to implement your hidden field variables when comes to HREF for anchor tag.

    Anyway, I used the same form you created and replaced www.jotform.com to http://www.malaysiatraining.net/2012/05/Knowledge-Hub-Asia.html without removing your "/", it works too. I will try the same way on my own form and let you know the result by tomorrow.

    Thanks.