My payment link stopped working for payments that go straight to square

  • Profile Image
    rickazrin
    Asked on July 14, 2021 at 10:59 AM

    This is the error I get when I submit the form (with all fields filled in), and this has occurred multiple times, despite all fields being filled in, although I did leave out a field that my form warned me to fill in, but when I did, I submitted and got this error, over and over:

    1626274299_60eef9fb1e38a_

    this is the form that is not working: https://hipaa.jotform.com/201947313877160

    I entered everything except the required referral source, got an error that some fields were still required, so I then enterred that field for the referral source, and then I submitted the form, with credit card information still there. That is when the error happened. I tried other forms and had the same problem, but intermittently (I think it is only when something was missing and an error about that missing required field was given, which I then filled in, that resulted in the intermittent nature of the problem), and I even tried charging my own card, and it still happened, sometimes. This error occurred at about 9:50am CST on July 14.


    If I then try to go back

    what should I do?

  • Profile Image
    Katherine_W
    Answered on July 14, 2021 at 03:55 PM

    Hi there,

    Happy to help!

    In checking your form, I can see that you have the Square integration connected to the form. As far as I can tell the connection is working and the form seems to be in good standing.

    However, the error you are mentioning occurs when there is a connection issue between Jotform and Square. This can be resolved by refreshing the connection to your Square account. Can you kindly try disconnecting your Square integration and then reconnecting again?

    If the issue persists, please log out of your account and clear your browser's cache and cookies and try again.

    We look forward to your response.