Empty my forms page

  • Profile Image
    Eric
    Asked on January 23, 2014 at 08:33 PM

    Hi. I have been having this problem for several weeks now sometimes clicking login will not work clicking on my forms will bring up the my forms page but nothing will load in the center of the page. Have tried this in IE, chrome, and firefox. Tried clearing cache. Did not help. Sometimes refreshing page 10+ times will fix the issue but there is something going on here more than it just being a browser issue.

  • Profile Image
    Welvin
    Answered on January 24, 2014 at 04:04 AM

    Hi Eric,

    Did you try to open the website using safe mode (add-ons/extensions disabled on your browsers) ? Kindly try it using Google Chrome and check if that makes a difference. I do not have an issue opening the website, and I am using an IP from your location.

    How about your network connection? Kindly ping jotform.us and see if it's good or not. Also, try to use Google Chrome DNS: https://developers.google.com/speed/public-dns/. See if this works for you. If yes, then there's a possibility that your network had a trouble connecting to our servers. Resetting your modem/router and flushing your DNS Cache should fix it.

    Thanks

  • Profile Image
    Welvin
    Answered on January 24, 2014 at 06:15 AM

    We have an update. Our developers have made a fix to this issue. Please kindly re-check again. Please force to clear your browsers cache by pressing CTRL + F5 for windows and CMD + Shift + R for OSX.

    Thanks