Some of my forms do not show up on firefox browser

  • Profile Image
    gottumblr
    Asked on June 30, 2011 at 11:16 PM

    I have serveral forms that do not show up on mozilla firefox browser please advise. 

     

    thanks jamie

  • Profile Image
    mliz
    Answered on July 01, 2011 at 05:37 AM

    Hi Jamie,

    Can you please post the url of these forms so that we can check it.
    So far I only found 1 untitled form on your account and it works
    both on Firefox and IE.

    We'll await for your reply.

    Thanks for using JotForm.

    Regards,
    Mliz

  • Profile Image
    gottumblr
    Answered on July 01, 2011 at 10:13 PM
    Thanks for your quick response. I only one form at the moment and what happens is when enter the url, the form pops up for just second then its gone. The url is:
    http://www.gottumblr.com

    thank you


    ________________________________
  • Profile Image
    NeilVicente
    Answered on July 01, 2011 at 10:37 PM

    Hi Jamie,

    I have handled a similar issue by another user who was also using Xara Web Designer. The problem is caused by an element in your page that covers the form when the page is viewed under any browser that is not IE.

    Solution to that problem is to move the form to the front layer. That way it will not be hidden by any other elements in your site.

    Here is the link to that similar issue - http://www.jotform.com/answers/32004-My-form-only-works-with-Microsoft-Exlorer

    Hope you find this answer satisfactory. Let us know if there's anything else you need assistance with. Thank you!


    Neil