API JSON

  • Profile Image
    EastPierDev
    Asked on July 27, 2021 at 08:35 AM

    Hello

    I have a workflow that depends on the Jotform API. Specifically, with the Product List field. It seems to be the case that when I try to get the values of a submission with an API call immediately after submission (triggered by webhook), the JSON does not include an 'answer' or 'prettyFormat' attribute for the product list field?

    Other fields in the JSON do have answers but the product list field does not.

    However when making the same API call later, the 'answer' & 'prettyFormat' attribute does exist.

    1627389194_60fffd0a4ecc8_1627389214_60fffd1e43646_

    Is this the case? If so, why?

  • Profile Image
    VincentJay
    Answered on July 27, 2021 at 12:24 PM

    Hi,

    Please share the form link so we can check it. Also, please try disabling these options in the account settings (https://www.jotform.com/myaccount/settings) and see if the issue still persists:

    1627403064_6100333878fea_vs463.png

  • Profile Image
    EastPierDev
    Answered on July 28, 2021 at 06:30 AM

    No, I handle a lot of sensitive information via my form & cannot make submissions available without login.

    The problem is a rare occurrence but is highly obstructive to the workflow when it happens. Why would the JSON differ over time?

  • Profile Image
    Hanne_L
    Answered on July 28, 2021 at 10:43 AM

    Hi there!

    I understand you are unable to share your form due to sensitive information. To assist to the best of our ability, may I instead ask for the exact API call you are using? This way we can try to replicate the same issue on our end.

    Look forward to hearing from you!