What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Revision history feature not reverting product quantities

    Asked by TSellers on February 03, 2014 at 08:36 PM

    When I bring up the revision history and restore a version from 2 hours previous it tells me that is was successful, says "Revert Completed". While still in that window, I see that the form I want looks correct. So then I hit the 'X' button to exit and go to my forms. I hit the edit for the form I restored from revision history, and all I can see there is a yellow triangle telling me to "Run the wizard for configurations". All my data for that field is gone. If I try to run the wizard, all you get is the ability to start adding items all over again, nothing that was restored appears. As far as I can tell, no revert has been completed. Am I missing a step, or is this highly touted feature not yet ready for prime time? If not it looks like I'm in trouble with 12 hours of lost work.

    Page URL:
    http://www.jotform.com/myforms/rev/40317545045247/ver/52f0436f60f63e29<br/>08000000

    My Forms height jpg items
  • Profile Image

    Answered by Cesar on February 03, 2014 at 09:57 PM

    First of let me apologize the inconvenience this may have brought you. I have been testing the form you speak of and I have been able to replicate the problem. I will raise a ticket in regards to your issue. Once the Dev Team has any updates to this, they will notify findings through this question. 

    Thank you.

  • Profile Image

    Answered by TSellers on February 03, 2014 at 10:33 PM

    Thanks for doing that, I'll keep my fingers crossed, I'm sure we all know the feeling of losing 12 hours of work!

  • Profile Image

    Answered by Cesar on February 03, 2014 at 11:36 PM

    You're welcome, I definitely understand your frustration. So it is best for the Dev Team to be aware of your predicament. Once they have an update, it should be provided via a notification through this thread. Thank you again.

  • Profile Image

    Answered by TSellers on February 04, 2014 at 12:07 AM

    Thanks for that. I've been playing with it just now to see if I can trick it back. The revision history can find the old form and restore it OK. The problem appears when I leave that page and try to edit. Then if you go back, the current version that is showing is no longer the one you restored. Once again you can restore the one you want, but it keeps getting orphaned when you leave the restore page. As I can still see the one I need, I'm hopeful that at some point I'll be able to get it back, probably just a minor glitch with this new feature that needs to be ironed out.

  • Profile Image

    Answered by Cesar on February 04, 2014 at 12:26 AM

    I did see that behavior as well while testing your form. I was unable to get back to the Form's Page as it should after choosing to retrieve your form. Thus probably cancelling out th e retrieval by going back through an alternate way. I have noted that behavior on the ticket I raised. Thank you for your input. This should give the Dev Team a clearer idea on what's going on.

  • Profile Image

    Answered by TSellers on February 04, 2014 at 09:26 PM

    Wondering if there has been any progress on this? What would be the normal time to expect to have the Dev's be able to trouble shoot the problem?

  • Profile Image

    Answered by pinoytech on February 05, 2014 at 12:11 AM

    @TSellers,

    Unfortunately, we haven't heard any updates from our dev team with regards on this issue. Don't worry, we'll inform you immediately once this issue sorted out.

    Thank you for your patiece!

  • Profile Image

    Answered by TSellers on February 05, 2014 at 12:26 AM

    Thanks pinoytech, I assume the revision history will not expire before then, salamat, much appreciated.

  • Profile Image

    Answered by TSellers on February 05, 2014 at 03:27 AM

    I thought what the heck and went back and tried again. First the form was the same, EG. the 'bad' version. So I went back into revision history, found the good one, restored it, then this time when I hit the edit button, the restored form was back. So either the dev's fixed it and forgot to let us know, or what I experienced yesterday may have been caused by something like a browser incompatability, except as you said, you were able to duplicate the problem. Now perhaps I should start to clone the forms when I'm working on them and try to keep the latest clone as a backup as well.

  • Profile Image
    JotForm Support

    Answered by jonathan on February 05, 2014 at 05:04 AM

    @TSellers

    Hi, thank you for taking the time informing us of the status on your end.

    The reported ticket is still with our developers and still open.

    It could be that they were already working to fixing it, and it reflected on your form at this time.
    They will still provide response on this thread when they have update on this.

    For the meantime, it is also good that you do the clone method as backup option.

    Thanks.

  • Profile Image

    Answered by TSellers on February 06, 2014 at 10:57 PM

    I guess I spoke to soon. I just started to edit the form for the first time since restoring it. I just realized none of the options are restoring, I tried a few more times, and no luck. Any chance to follow up with the Dev Team and get their thoughts on this?

  • Profile Image
    JotForm Support

    Answered by abajan on February 07, 2014 at 05:41 AM

    The extra info will be forwarded to our Chief Technology Officer (the developer to which the ticket has been assisgned). We'll keep you updated on any resolution of the issue.

    Our apologies for the inconvenience.

  • Profile Image
    JotForm Support

    Answered by abajan on February 07, 2014 at 06:19 AM

    @TSellers,

    Could you please clarify? When you state that none of the options are restoring, do you mean that the form is not saving any changes made since restoring it?

  • Profile Image

    Answered by TSellers on February 11, 2014 at 01:53 AM

    Yes, that's correct, the form restores correctly. But then when you go to edit that restored form, all the options have not come across. Probably easiest if I show screenshots of what I mean. First the restored form looks as so, note the Qty and Size fields are there:

    Next after you exit the revision history screen where the above was restored. and then go to edit your form, this is what you see, you'll note that Size and QTY (and color) options are not present anymore:

     

    Thanks for following up on this.

  • Profile Image
    JotForm Support

    Answered by EltonCris on February 11, 2014 at 03:16 AM

    @ TSellers 

    Thanks for the additional details. I was able to reproduced the problem. I have now informed our developers about the problem. You will be updated here once this is fixed.

    Our apologies for the inconveniences caused.

  • Profile Image
    Chief Technology Officer

    Answered by eee on February 11, 2014 at 03:41 AM

    Hi TSellers,

    Problem has been solved,

    Thank you for reporting it,

    Kindest Regards,

    Ertugrul.

  • Profile Image

    Answered by TSellers on February 11, 2014 at 04:11 AM

    Yes, working for me now, thanks very much for following up on that.