When inserting a page break, the buttons "next" and "previous" are not shown in right language

  • Profile Image
    mlarniem
    Asked on July 05, 2011 at 10:49 AM

    Hi, I have a form for German users and there is a problem with the buttons to go to another page. Sometimes they are shown in German, which is right, but sometime in English, which is incorrect.

    How can I fix this?

    Thanks,

    Lars

  • Profile Image
    NeilVicente
    Answered on July 05, 2011 at 11:22 AM

    Hi Lars,

    Whenever you edit and save your forms, the pre-made form elements, such as page breaks and the months in date fields will save in the language that you have set the Form Builder to.

    Thus, you need to always make sure that the language option of the Form Builder is set to your preferred language when modifying and saving your form.

    Anyway, I went ahead and re-saved your form in Deutsch. The page breaks correctly display on my end now. Please confirm if you see the same on your computer.

    Let us know if there's anything else you need assistance with. Thanks!


    Neil

  • Profile Image
    mlarniem
    Answered on July 05, 2011 at 11:40 AM

    Thanks, seems to work fine now...

    Another one: the optional "other" field with the radio button selection isn't translated, is it? It stays English...

  • Profile Image
    Bill
    Answered on July 05, 2011 at 11:40 AM

    @NeilVicente


    Could you please tell us where do we find the Language selection?

  • Profile Image
    NeilVicente
    Answered on July 05, 2011 at 12:12 PM

    @mlarniem

    Unfortunately, that does not get translated. I think it may have been left out by our developers. I will submit a ticket to notify them of this issue.

    You will be contacted via this thread if this gets fixed soon enough. Thank you for your patience and understanding.

     

    @Bill

    The language option can be found by scrolling way down the Form Builder. It is in the footer, alongside the log in area.

     


    Neil

  • Profile Image
    Bill
    Answered on July 05, 2011 at 01:11 PM

    My Language is not there :(

  • Profile Image
    NeilVicente
    Answered on July 05, 2011 at 01:36 PM

    Hi Bill,

    I apologize but those are the only languages available with Jotform. If you want to request to have your language added, please create a separate thread for it so I can submit a feature request ticket. And please don't post any more questions here that are not related to the original topic at hand. Thanks!


    Neil

  • Profile Image
    mlarniem
    Answered on July 12, 2011 at 02:59 AM

    Hello again, same problem and no way to solve it although saving the form again. On http://form.jotform.com/form/11740901306 the language is English where it means to be German, in the formbuilder it is German...

  • Profile Image
    NeilVicente
    Answered on July 12, 2011 at 03:11 AM

    Hi,

    Please use this link instead - http://www.jotform.com/form/11740901306

    Thanks!


    Neil

  • Profile Image
    mlarniem
    Answered on July 12, 2011 at 03:19 AM

    Thanks Neil, it works :-) ... a bit confusing though because the first
    link I got from the embed options...

  • Profile Image
    NeilVicente
    Answered on July 12, 2011 at 03:31 AM

    Hi,

    I understand that the link is provided by the Embed Form wizard. Forms that use the link form.jotform.com are  served from a Content Delivery Network, which finds the best server for your location (for faster speed). However, there have been some issues with regards to the updating of the forms in some locations.

    We are currently working on it. Apologies for any inconvenience caused.


    Neil

  • Profile Image
    mlarniem
    Answered on July 12, 2011 at 06:08 AM

    again :-( ... even with the other link you provided...

    the form just went online and was communicated, hope people don't get confused.

  • Profile Image
    NeilVicente
    Answered on July 12, 2011 at 12:21 PM

    Hi,

    Again, like I said, only save the form while the language is set to 'Deutsch'. That is the only remedy to this.

    Does anyone else have access to your account? It could be that they log in to Jotform and did not choose 'Deutsch' in the language and then the form was saved, since it auto-saves by default.

    Try disabling auto-save so that it does not get saved when you edit your form in a new browser (which defaults to English as the language).

    To disable auto-save:

    1.  Right click in a whitespace (any space which does not contain fields)

    2.  In the context menu that appears, click Disable Auto-save

     

     

    Hope this helps.


    Neil