Problems with Source Code Embed form

  • Profile Image
    Guscott
    Asked on August 21, 2021 at 10:49 PM

    I am using the Full Source Code embed option on our website here: https://www.knowyourweeds.com/contact

    Since moving from the iframe embed to Source Code, I'm now having two problems:

    1. A separate JotCaptcha appears after filling out the form even though I already have recaptcha

    Same issue as here: https://www.jotform.com/answers/2699565-additional-captcha-is-showing-on-form-embedded-with-source-code

    Based on that answer, my Jotform username needs to be whitelisted by you manually.

    2. "Upload Error" when trying to attach a file using the file upload field

    1629600176_6121b9b0bc95a_

    The form submission fails completely when a file is attached. I'm just testing with a small PNG file, so not a problem with size or file type.

    Related: My test submissions with no file still have some kind of file attachment (text link?) in the submissions table. This isn't a problem but could be related to why the file upload option is no longer working.

    1629600370_6121ba722d4ca_

    I'm moving to the Source Code option so that the form loads faster and to avoid any issues some users may have loading the iframe on certain devices, so I'd love to solve these problems instead of changing the embed option!

  • Profile Image
    Guscott
    Answered on August 22, 2021 at 03:04 AM

    I think this is solved.

    I noticed that there was a recaptcha error in the console (missing sitekey). I tried both deleting & re-adding the recaptcha to the form (and updating the code) and also replacing the site key in the source code for one for my domain. Neither fixed it.

    I switched to hCaptcha and now both problems are gone - there is no separate JotCaptcha page and file attachment works ok.

    hCaptcha is a bit more tedious to complete but this is an ok solution for now!

  • Profile Image
    jonathan
    Answered on August 22, 2021 at 03:34 PM

    Thank you for taking the time updating us on the status and letting us know all is good now. Contact us anytime should you require further assistance.