What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    How can we get the integration fixed with JotForm and Form Generator for Wordpress?

    Asked by aaapubadj on February 11, 2014 at 03:43 PM

    When entering my key information into Form Generator for WordPress (see attached screenshot), I click Connect with JotForm and nothing happens.  Is this a valid key.  Is there something else in my account settings with you guys, that need to be done to make the domain respond to your interface?

     

    My authorized apps is blank.... but the Form Generator for WordPress plugin is supposed to authorize the site. Is there anything you can do?  This plugin is supposed to allow us to EDIT THE FORM within the website.

     

    Thank you.

    Screenshot
    form generator JotForm and domain settings
  • Profile Image
    JotForm Support

    Answered by EltonCris on February 11, 2014 at 04:41 PM

    Hi,

    Did you logged in to your Jotform account first?

    Please try the following.

    1. Login to your Jotform account first.

    2. Open your WP and reconnect using the API Key taken from Jotform.

    Let us know if this doesn't help.

    Thanks!

  • Profile Image

    Answered by aaapubadj on February 19, 2014 at 09:35 AM

    I did try the following steps, to no avail.  Any additional thoughts?

    Also, this problem started happening once I switched domain names, would that have any affect?

  • Profile Image
    JotForm Support

    Answered by jonathan on February 19, 2014 at 09:51 AM

    Hi,

    Can please try generating new API Key in your JotForm account and use that for the WP connection.

    During the integration make sure that in the authentication proceess the domain being authorized is your domain name.

     

    Please try this method and inform us if still not working.

    Thanks.

  • Profile Image

    Answered by aaapubadj on February 19, 2014 at 10:11 AM

    Hi Jonathan,

    The problem is that I'm not getting this pop-out box.  Also I've tried to uninstall and reinstall the Form Generator for WordPress.  Any further thoughts?

  • Profile Image

    Answered by Cesar on February 19, 2014 at 10:19 AM

    Has the addon given you any errors when installed? If possible do also try Chrome or clearing your browsers cache and logging back in to your JotForm & Wordpress account and retry the process.

    Do let us know if the issue persists. Thank you.

  • Profile Image

    Answered by aaapubadj on February 19, 2014 at 10:44 AM

    No, there weren't any problems when I installed the plugin.

    I tried using Chrome and definitely cleared out cache.

    I then logged into my JotForm account in one tab and logged into WordPress in the second tab.

    I also made sure pop-ups were not blocked, but when I click the CONNECT WITH JOTFORM button, the page refreshes (with no authorize box) and refreshes the Settings page.

    So I'm still having the issue.

    Is anyone available to do a screen share with me?

  • Profile Image
    JotForm Support

    Answered by NeilVicente on February 19, 2014 at 11:44 AM

    Form Generator for Wordpress is a third party app and is not maintained nor supported by the JotForm team.

    I've tested the plugin on my end as well but it does not work as it claims to be.

    I'd suggest contacting the developer responsible or this plugin here:

    http://watchstreetconsulting.com/form-generator-wordpress/

    As an alternative, you may just simply use the JotForm site for managing your forms, and embed them to your wordpress site using the official Wordpress Embed Plugin

  • Profile Image

    Answered by aaapubadj on February 19, 2014 at 01:25 PM

    Thanks, NeilVicente.  I'll reach out to the plugin developer.

  • Profile Image

    Answered by socalnetwork on March 18, 2014 at 11:38 PM

    Was there ever a solution for this? I am having the exact same issue. seems by the looks of the threads on this that this is not an isolated issue. Has anyone gotten it to work? I am so frustrated trying to get this to work correctly.

  • Profile Image
    JotForm Support

    Answered by ashwin_d on March 19, 2014 at 07:50 AM

    Hello socalnetwork,

    As suggested by my colleague above, you should use JotForm site to manage forms. The Form generator for workpress is not developed by JotForm, it is a 3rd party app.

    I would suggest you to use the JotForm plug-in to embed your form in wordpress. The following guide should help you:  http://www.jotform.com/blog/83-Embed-Form-Plugin-for-Wordpress

    Thank you!