What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Date/Time Properties undefined

    Asked by kreinhardt on February 13, 2014 at 11:41 AM

    Attached is a screen shot of the Properties screen for my Date/Time field.

    I wanted:

         Default Time to Yes

         Disable Past Dates to Yes

         Minute Stepping to 15

    I change the and Close Setting and it none of the settings work on my form, so I go back to the Properties screen and attached is what I see...they are all set to undefined.

    Page URL:
    http://www.midwestmoving.com/nurequest/

    Screenshot
    properties settings time field attached
  • Profile Image

    Answered by Carina on February 13, 2014 at 12:51 PM

    I performed some tests in a copy of your form and could replicate the situation you describe. I then erased the date/time field and inserted a new one and was able to successfully make the changes.

    For some reason that field stop updating properly, but it can be solved by inserting again.

    Kindly let us know if you need more assistance.

     

  • Profile Image

    Answered by kreinhardt on February 13, 2014 at 03:56 PM

    Thank you for the quick response.  I have tried to remove the entire field and start over multiple times and I get the same result every time.  I will continue to try it until I get it or I see a different solution.

  • Profile Image

    Answered by Carina on February 13, 2014 at 04:06 PM

    Perhaps is a browser cache issue. Please try to erase your browser cache.

    You can also clone this form (which is the same as yours, but with date/time field working properly):

    http://form.jotformpro.com/form/40436268682965

    If this still doesn't solve the issue, I kindly ask to tell us what browser (and version if possible) are you using so we can look better into this.

    Let us know if the problem persists.

     

  • Profile Image

    Answered by kreinhardt on February 14, 2014 at 03:35 PM

    The cloning worked.  I did not try erasing my cache.  Thank you so much for your help.

  • Profile Image

    Answered by kreinhardt on February 17, 2014 at 12:00 PM

    I ended up needing to split the Date and Time as we determined the Date needed to be required, but the time didn't.  I don't want a default time, but I want to change the minute intervals to 15 minutes and I'm running into the same problem again.  Can you help again?

    http://form.jotform.us/form/40445670620146

  • Profile Image

    Answered by EliezerN on February 17, 2014 at 01:18 PM

    @kreinthhardt

    If the issue regarding to the date settings not being saved still persists try clearing your form caches from the Account page, you can follow the steps of this guide to learn how to do it: How to clear your form cache I have also done that from our side.

    I made a test with one of my forms and it worked just fine. 

    Kindly inform us if clearing the form caches resolve the issue, if not, do not hesitate to contact us.

    Thanks

  • Profile Image

    Answered by kreinhardt on February 17, 2014 at 01:45 PM

    Clearing my cache did not help.  I've been working on IE11, so I tried both FireFox and Chrome and still had the same problem, so I also went to another computer of mine that has IE 8 and I still have the same problem.  No luck.

  • Profile Image

    Answered by EliezerN on February 17, 2014 at 04:05 PM

    Thanks for the information.

    At this time I went a head and tried to made the changes directly from your account and I was able to reproduce the issue just as you described. I updated your form using secure mode of the form builder (usin htpps://) at the first time.

    Then I tried the builder not using https://, but http:// instead and the change was correctly applied and reflected to your form, then I went to MY FORMS page and returned to the form in the builder and the setting was still there, so it worked fine.

    Please see this .gif file while I was editing your form using htpp:// instead of https://:

    (click on the image to make it bigger)

    So, could you please let us know if you were editing your form while using the Secure mode of the form builder? If so, kindly try logging in usin this URL at this time: http://www.jotform.us/

    Then clone your form and try to make the changes to the cloned version of your form, it should work fine at this time. Here is your form already fixed: http://form.jotform.us/form/40445670620146

    If the issue still persists, kindly get back to us so that we can further investigate and forward this issue to our next level support if necessary.

    Thanks

  • Profile Image

    Answered by Kevin  on February 17, 2014 at 04:38 PM

    This worked perfectly, thank you.  I logged into http://www.jotform.us, cloned my form and was able to change the Date/Time properties to anything and none of them appeared as undefined.

    Thank you.