What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    My form is not showing and my some links are not working.

    Asked by kevinguaptree on February 18, 2014 at 05:47 AM

    As I navigate the site I am finding many areas that are simply unavailable.  The areas of primary concern to me are the My Forms tab comes up with a blank white space and only the Create Form and Sort dropdown available.  Neither of them has any functionality.  From that screen I am only able to use the Pricing tab along the top of page. 

    If I reload at this point I am sometimes able to select another tab from along the top, with Plugins and Support dropdowns functioning.  From those areas I am able to then select the Profile button along the top, however there is nothing in the profile area.  Blank white space and the tabs along the left hand column have no functionality. 

    At first I expected to be able to flush the cache to resolve the issue, though this is not possible as the appropriate tab does nothing upon selection.

    I have done everything I know to do from my end, flushing the cache and DNS, updating Firefox and power cycling the PC to rule out most things on my end.

    The only other issue on my end I see may be a source is if there are settings in the browser which the site requires but are suboptimally configured in the browser settings.

    Any assistance you are able to supply is greatly appreciated.

     

    Kevin

    Screenshot
    My Forms create form source cache
  • Profile Image

    Answered by jedcadorna on February 18, 2014 at 06:56 AM

    Hello Kevin,

    Thank you for contacting us.

    Your form does display correctly on my end. Have you tried to reset your firefox to default? Jotform.com domains works on my end i'm not quite sure if the problem is base on the region. Have you tried using a different browsers or computers?

    Kindly check if javascript is correctly loaded in your firefox please check it here http://enable-javascript.com/ some files might not be loaded correctly that is why some of the links are not working. Well I doubt that your JS is disabled since you were able to login but you are not just seeing your form.

  • Profile Image

    Answered by kevinguaptree on February 18, 2014 at 07:42 AM

    Thanks a ton jedcadorna!  Resetting Firefox resolved the issue.  Back to work for this guy.