API: Unable to create form questions.

  • Profile Image
    bishalpapan
    Asked on September 21, 2021 at 08:56 AM

    I am trying to create a form using my Jotform API key according to the documentation in Jotform API. I am using the following data as shown:


    1632228800_6149d5c0ba9f2_Screenshot (196

    As you can see, the trial is successful. But when I go to the form URL, the form shows empty, like this:

    1632228859_6149d5fbe2bc0_Screenshot (197

    The form also shows empty in my forms' list in My Forms | Jotform. What might be the possible reason and solution for this?

  • Profile Image
    Anthony_Evans
    Answered on September 21, 2021 at 04:04 PM

    Howdy bishalpapan,

    I have tested this and I was unable to encounter any errors. However, I have entered 1 for the order parameter.

    1632254543_614a3a4fd9005_

    Here is the resulting form.

    1632254586_614a3a7ad7854_

    Please let us know if you continue to see a blank screen when creating a new form with a question at order 1.

    Thank you for your patience and understanding!

  • Profile Image
    bishalpapan
    Answered on September 21, 2021 at 04:12 PM

    Hi Anthony_Evans,


    This is weird, but still I am facing the same issue

    1632255077_614a3c659d91b_Screenshot (199

    In the form URL link:

    1632255144_614a3ca8c7b97_Screenshot (200

    In the form details view:

    1632255396_614a3da4b8a8a_Screenshot (201

  • Profile Image
    Anthony_Evans
    Answered on September 21, 2021 at 06:38 PM

    Hello again,

    I have tried creating another form using your exact inputs. However, I'm still getting the expected result.

    The only thing left that can be making this difference is the API Key that's being used. So, I have logged in with your account and attempted to use both API Keys, however I ran into the same issue that you have. I've also deleted both of the keys and generated a new one, but the same issue is still occurring.

    I've been unable to replicate this issue on a brand new account. In the meantime you may wish to try creating a new account and trying out the newly created API Keys.

    At this time I have alerted our developers to your issue. Please understand that we are unable to provide an ETA for when this issue will be resolved. However, once there is an update you will be notified directly on this thread.

    Thank you for your patience and understanding!

  • Profile Image
    bishalpapan
    Answered on November 15, 2021 at 08:08 AM

    Hi Anthony,


    I appreciate the steps you had taken earlier. Pardon me for this late follow-up. Have you found a solution to this issue? I have not tested the API yet. But is this issue resolved or any update that you can share? Thanks in advance.

  • Profile Image
    Durand_C
    Answered on November 15, 2021 at 10:17 AM

    Hi @bishalpapan,

    Thank you for contacting us.

    I apologize for the delay.

    Our Developers are working on the problem and you will be informed if there is a solution

     Best regards,

    Durand