If Authorized.net payment question is marked as required, it always displays the required field validation error.

  • Profile Image
    patriccia
    Asked on February 27, 2014 at 08:21 PM

    Hello,

     

    Payment tool is not working for authorize.net.  When my customer put in their credit card information.  Name and address, credit card number.  They gets errors, stating that they need to complete the field.

     

    I also tried to submit a form for payment and got the same error.  Is this tool down.

  • Profile Image
    ashwin_d
    Answered on February 28, 2014 at 02:19 AM

    Hello patriccia,

    I'm sorry for the trouble caused to you.

    I was able to replicate the exact same problem you are having. If the authorized.net payment question is marked as required, it does not allow the form to be submitted. Even if all the form fields are filled, it displays required field validation error always.

    I am creating a bug report and forwarding it to our back end team. We will get back to you as soon as we receive any update on this.

    Thank you!

  • Profile Image
    patriccia
    Answered on February 28, 2014 at 11:40 AM
    New response receivedHello,
    Thank you for replying back. I have resolved the issues. I delete the form and put in another one and it is working now.
    Patricia Shaw
    ...
  • Profile Image
    ashwin_d
    Answered on February 28, 2014 at 01:56 PM

    Hello Patricia,

    I am glad to know that you were able to resolve your issue.

    Do get back to us if you have any questions.

    Thank you!