What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Submit Button not appearing in frontend

    Asked by kekepikentron on March 07, 2014 at 08:07 AM

    Hallo!

    i have a problem when i embed by form into my website. Everything in form is ok except for the submit button that doesn't appear. I searched the forum and i saw some similar problems. Perhaps it has to do with height properties. I increased the height in iframe code but nothing happened.. Do you know what may cause this problem and how can i fix this?

    I use JCE EDITOR for the embeded code

    You can see this form in my site http://vouchernews.gr/index.php/16-aitisivoucherathina

    An here http://form.jotformeu.com/form/40646608396362

     

    Wait for your answer

     

    Timothy

    iframe code problem height site
  • Profile Image

    Answered by Carina on March 07, 2014 at 09:52 AM

    Hello Timothy

    After checking your form's source code I noticed that you have 2 height values for the iFrame.

     

    But after running some tests I saw that the height value gets ignored if we use the complete iFrame embedding code. I forwarded this situation to our developers, but meanwhile if you wish you can embed this code instead:

    <iframe id="JotFormIFrame" onload="window.parent.scrollTo(0,0)" allowtransparency="true" src="//form.jotformeu.com/form/40646608396362" frameborder="0" style="width:100%; height:1400px; border:none;" scrolling="no"></iframe>

    You will be updated through this thread once they have news.

    Let us know if we can be of more assistance.

  • Profile Image

    Answered by kekepikentron on March 07, 2014 at 10:42 AM

    Hallo!

    Thanks for the answer, but i'm afraid the problem remains..I should wait for your update!

     

    Timothy

  • Profile Image
    JotForm Support

    Answered by ashwin_d on March 07, 2014 at 11:54 AM

    Hello Timothy,

    Which browser are you using? I did check your web page in chrome and mozilla and was unable to replicate the problem you are having. Please check the screenshot below:

    Chrome: 

    Mozilla:

    Have you solved the problem already?

    We will wait for your response.

    Thank you!

  • Profile Image

    Answered by kekepikentron on March 10, 2014 at 04:21 AM

    Hallo!

    Well it seems that there is problem that has a connection with jce editor properties in joomla

    When i embed the form via iframe no buttons appear..(the strange is that i have enabled the option to accept iframes)

    When i embed the form via joomla the buttons appear but i have another problem...the translated fields in Greek remain in English...what can i do for this?

    I wait for your answer!

    Timothy

  • Profile Image

    Answered by kekepikentron on March 10, 2014 at 04:25 AM

    Hallo!

    Never mind what i said before..Finally the problem is solved!The embed via joomla option works fine and the translated fields appear fine!

    Thank you for your support!

    Best Regards

    Timothy

  • Profile Image
    JotForm Support

    Answered by ashwin_d on March 10, 2014 at 08:14 AM

    Hello Timothy,

    I am glad to know that your problem is solved.

    Do get back to us if you have any questions.

    Thank you!