What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Hidden fields in Submission View

    Asked by mgcaledonian13 on March 13, 2014 at 01:42 PM

    I had a hidden field (UniqueNumber) in the View and it took me ages to work out why the whole app did not "produce the goods" and with a bit of deletion of fields one by one I discovered it was the Unique Number that was the problem. As I have not tried any other hidden fields in the app I would like to know if a hidden field other than a Unique Number works OK. I'll try it with a Test Form when I have a moment. Tried it and hidden fields kill the view.

    I would like to flag up the fact that a URL to a website page does not work either, again it kills the view altogether likewise an email address.

    The developer shows the email but not as a mailto, that means the user viewing the page has to copy and paste the email address into their mail client in order to contact the person that uploaded the information, in this case a Honda Motorbike for sale.

    ***  Could JotForm ask the developer of this app to look at these two last possible features being included.

    Regards Willy MG

    hidden JotForm email problem style size
  • Profile Image
    JotForm Support

    Answered by Mike_T on March 13, 2014 at 05:06 PM

    Are you referring to the Submission View App? If possible, please provide us with the steps to reproduce mentioned issue with the Unique ID field.

    I would like to flag up the fact that a URL to a website page does not work either, again it kills the view altogether likewise an email address.

    Is there a link that we can check?

    The developer shows the email but not as a mailto, that means the user viewing the page has to copy and paste the email address into their mail client in order to contact the person that uploaded the information, in this case a Honda Motorbike for sale.

    Please confirm that you would like to have clickable 'mailto' links on Submission View / List View page, and we will see if there are any options.

  • Profile Image

    Answered by mgcaledonian13 on March 13, 2014 at 06:55 PM

    Sorry the text was copied from a thread that it should not have been in, so that is why it does not specify.

    Yes I am referring to Submission View.

    Regarding a link to check, I will use Form Builder tomorrow to create a "Test Form" to show what the problem is.

    An Email 'Mailto' can be inserted and works OK on the preview but when the 'iframe' code is pasted into the Webpage it kills the process of the 'Listing' and or ' The View'. Seems strange that it works OK in the 'Preview' and not the actual page.

    Does that make sense now, I hope so !!

    Regards Willy MG 

     

     

  • Profile Image
    JotForm Support

    Answered by EltonCris on March 13, 2014 at 11:10 PM

    Hi Willy,

    Would you mind providing to us the website URL where you've embedded your submissions listing so we can see the difference? This might help us identify the root cause of the problem.

    I just created a sample submissions listing out of my form submissions and then embedded the form, so far it's working fine here. https://shots.jotform.com/elton/test_submissions_view.html

    We'll await your reply. Thanks!

  • Profile Image

    Answered by mgcaledonian13 on March 14, 2014 at 02:58 AM

    Yes I can see that that works OK. I can do the same, but try putting in a 'mailto' in the code  and or a 'Hidden Field' like 'Unique Number' in the Form and see what happens.

    For the 'mailto' I used <A HREF="mailto:no-one@snai1mai1.com?subject=look at this website&body=Hi, I found this http://www.geocities.com/wowhtml/"></A>

    I will do the Demo Form later today so that you can see what happens with my form.

    Regards Willy MG 

  • Profile Image

    Answered by mgcaledonian13 on March 14, 2014 at 08:54 AM

    OK I have two form made up they are :-

    This one has the 'email and hidden fiels' 

    http://form.jotformpro.com/form/40713585379968

    This one has 'NO email and a hidden field'. It is a clone of the one above, it does not work either possibly because it is a clone and there is some stray code lurking in it from the previous one

    http://form.jotformpro.com/form/40723128062951

    This is one that works OK and was buit ealier, this one has a hidden field that I am not displaying as it kills the Views 

    http://form.jotformpro.com/form/40466986732971

    You could also go to http://www.mgcaledonian.com/parts-for-sale-viewer/ and see the http://form.jotformpro.com/form/40466986732971 live on the site

    I hope this helps identify the cause of the Hidden and email fields killing the Views.

    Please feel free to add your own submissions to any of these, I can delete yours later!!  

    Regards Willy MG

  • Profile Image
    JotForm Support

    Answered by TitusN on March 14, 2014 at 02:26 PM

    Hello,

    Thank you for the update, and the test forms.

    Currently running some tests, will update you once they are complete.

  • Profile Image
    JotForm Support

    Answered by TitusN on March 14, 2014 at 03:05 PM

    Hello,

    Thank you for your patience.

    We're having a little difficulty reproducing your issue...

    I conducted the following tests:

    1. cloned your form, and ran some submissions

    2. Opened up the submisison view app

    3. added in the anchor tags for the email field with a mailto attribute

    4. Published the iframe on a sample page - it worked

    5. Added in a hidden field - refreshed the submissin view page - the mailto links were still present.

    I then did some independent tests.

    1. Created a form similar to yours: http://form.myjotform.com/form/40725860749564?

    2. Did the same test as listed above - and the mailto attributes were not broken or stripped - https://shots.jotform.com/titus/Iframetest2.html - please note that the source form has a hidden field within it - which are the ones causing the mailto href attribute to break.

    The next question would therefore be:

    1. Show us the location where you have published the submission view iframe with broken links

    2. Show us a location where you have published the submision view iframe with correct links

    We will take a look and advice.

    Thank you for your patience.

  • Profile Image
    JotForm Support

    Answered by TitusN on March 14, 2014 at 06:03 PM

    Your Previous Response:

    Answered by mgcaledonian13

     

    Well at the moment all seems to be OK.

    I do not know what I was doing wrong but that all seems to work now and I can only thank you for all your patience in sorting out a problem that appears not to have been there.

    I am sure I did it all correctly, anyway it is sorted.

    Thanks.

    Regards Willy MG 

    PS     Feel a bit foolish

    ****

    No worries - we're here to help.

    Please let us know if the problem persists, and thank you for helping us with the troubleshooting process.