Calculation fields are empty after using populated fields.

  • Profile Image
    ocstokrode
    Asked on November 06, 2021 at 03:45 PM

    Hi, I have something strange...

    (1) In one of my forms (form 20) I have a field "Huurbedrag"
    (2) When I fill in an amount in this field some calculations will be made in other fields (marked in my screenshot with a red line). This calculations are for VAT issues.
    This calculations are using conditions. WORKS PERFECT

    1636226834_6186d7121f39e_huur manual.png

    However...
    I'm using another form (form 4) and with populated fields I will transfer the value of a lot of fields from (form 4) to (form 20). Also including the field "huurbedrag".
    When the field "huurbedrag" will be filled by using populated fields, the field "huurbedrag" will get his value. So that's also OK.

    BUT...

    There will not be made any necessary calculations for the other fields. This other fields will stay empty... ! (in my screenshot marked with ?)

    1636227055_6186d7efa88fb_huur via popula

    And also, when using I overwrite the value in the field "huurbedrag" when using the populated fields transferred from the first form, nothing will happen.
    Yes I can change the value of "huurbedrag" but the calculation fields stay empty.

    Any idea what will be the reason?
    And also... how to solve... ???
    Many thanks !

    Form 20: https://form.jotform.com/211691313747052
    Form 4: https://form.jotform.com/202644767658367














  • Profile Image
    ocstokrode
    Answered on November 06, 2021 at 03:47 PM

    Please when you test use a copy of the form. Cause otherwise invoices with an unique number will be generated...

  • Profile Image
    Kenneth_C
    Answered on November 06, 2021 at 04:48 PM

    Thank you for reaching support,

    Please use this app to accurately generate the Pre-Populated URL: https://prepopulate.jotform.io/.

    As form pre-populating field via URL, please follow this guide: https://www.jotform.com/help/71-prepopulating-fields-to-your-jotform-via-url-parameters/.

    Upon checking the forms, I do not see redirection to another page on the Thank you page.

    Let us know if you have any further questions.

    Best.

  • Profile Image
    ocstokrode
    Answered on November 06, 2021 at 06:14 PM

    Hi Kenneth


    Thanks for your answer.

    But it hasn't nothing to do with the right pre-populated URL or something...

    Cause the fields 1, 2, 3... 7 are NO populated fields. They will NOT come from the first form.

    In the first form this fields even don't exist.


    It's in the second form (the form below) the calculations are made. So when you fill an amount in "huurbedrag" in this form, all fields from 1 till 7 will make the calculations.


    It works as long you're working in the form directly.

    When you open the form using a link in an e-mail with populated fields, ONLY the field huurbedrag will be filled (value coming by the first form). That field works as it has to do !!! But the calculations will not be made. The calculation fields stay empty ???


    My question is: why it stops now?

    There's a value in "huurbedrag" and there are conditions. Right ?

    So why the conditions will not do their job anymore and calculate the value into the other fields 1,2,3,4,5,6,7 ?

    That's the question... :-)




    1636236281_6186fbf9d737b_huur manual 2.j

  • Profile Image
    Katherine_W
    Answered on November 06, 2021 at 07:19 PM

    Hi there,

    Happy to help!

    I made a clone of your form https://form.jotform.com/211691313747052 and noticed that this condition at the very end of the form has some missing fields - did you recently make changes to the fields?

    1636240656_61870d107057b_

    If you correct this condition, does the issue persist? I am also asking my Dutch colleagues to look into this to check the fields on your form.

  • Profile Image
    ocstokrode
    Answered on November 07, 2021 at 01:59 AM

    Thanks Katherine

    I have removed the last condition with the missing fields. That were old things and I forgot to remove the condition. Nothing to do with the fields I mentioned. Also no relation between them.

    But I found something else, and maybe the reason.
    There is a field number 3 (bedrag kortingen huur) and this field will get the value from another field in the form (korting).

    I just looked to this field {kortingStokrooie} and I saw this field got his populated value in an incorrect format. And now I'm looking in the first form (who got also populated fields from another third form (do you still follow :-) and I detect that I made a wrong command in the calculation/condition.

    I programmed for a value that has to be counted if field A is empty, put value '-' in field B
    And with field B later calculations has to be made and of course here it goes wrong.
    I have changed the condition now into if field A is empty, put value '0' in field B
    And with a '0' he can calculate of course.

    Now I will test it...

  • Profile Image
    VincentJay
    Answered on November 07, 2021 at 03:02 AM

    Hello,

    Do you still need assistance? We also recommend finishing all your conditions and don't leave something like this:

    1636272092_618787dc61fa6_af21aa.png

    It can create conflicts on your form even if it is not related to the issue. Let us know if you still need help after testing the form. Thank you!

  • Profile Image
    ocstokrode
    Answered on November 07, 2021 at 02:48 PM

    Thanks, you can close this ticket.

    Best regards.