Why are my forms not saving? Have had to redo my form four different times.

  • Profile Image
    lettyspain
    Asked on March 20, 2014 at 10:55 AM
  • Profile Image
    ashwin_d
    Answered on March 20, 2014 at 11:52 AM

    Hello lettyspain,

    I'm sorry for the trouble caused to you.

    Do you mean to say that your form is not getting saved at all or you are missing some form fields? 

    First of all, I would suggest you to clear your browser cache. That should solve your problem if it is related to cache issue. The following guide should help you clear browser cache:  http://www.wikihow.com/Clear-Your-Browser's-Cache

    If you are missing some form fields or if they seems to be deleted, please be noted that you can take advantage of "Revision History" feature and revert your form to an earlier version. The following guide should help you:  http://www.jotform.com/blog/95-Introducing-Form-Revisions-Never-Lose-Your-Work-Again-

    Do get back to us if the issue persists.

    Thank you!

  • Profile Image
    lettyspain
    Answered on March 20, 2014 at 12:01 PM

    Thank you for your response.

    My form is not saving at all...I keep clicking the save icon and it shows that it is "working", but when I log out and log back in, the saved file is gone.

    I tried the "wikihow" link you provided and this the message I received:

    Clear Your Browser' rel=

    The revision #13020943 of the page named "Clear Your Browser' rel=" does not exist.

    Any help you could provide is greatly appreciated. :-)

  • Profile Image
    KadeJM
    Answered on March 20, 2014 at 01:52 PM

    I took at your account and I can see that you are a subuser of HolySpirit. I decided to take a look at one of your form's ( http://www.jotform.us/form/40774559264161 ) for example but I only found 1 Revision listed for it within the past 3 hours. 

     

    I then took a look at a second form shared with you ( http://www.jotform.us/form/40774884095164 ) both of which show recent changes made yesterday and on this one it showed a saved revision that you could possibly revert to if you wanted to do so.

     

    Additionally I tested this several times on my test account with both an old form and a new form and I could see revisions being listed each time I went in and out of the form.

     

    So as of right now I am wondering more about which form were you having trouble with on which form are you seeing this not saved on your end?

    It is generally not a good idea to keep clicking on a button several times in a row since usually that can often cause unforseen problems such as when trying to submit a form creating multiple submissions for the form in example. About the only time it is okay is after giving it a moment to see if it's working and then when it's obvious its not then try to see if it is working or not per say.

    I've gone ahead and cleared your form cache from our end so I would next advise for you to please try clearing your browser cache incase there is some sort of minor cache glitch occuring. After that try clicking on the save button once and wait a minute to allow it time to see if it will kick in or just wait and the autosave portion should kick in unless you've disabled it.

    Please let us know if you continue with this problem and additionally may we know what browser/browser version you are using? Perhaps try it in a different browser on your end to see if you experience the same problem.