What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Conditions no longer working on form

    Asked by vermontzen on March 20, 2014 at 05:01 PM

    Hello,

    I created a registration form with two conditional fields, both of which have suddenly stopped working. They work in the preview, but not when the page is uploaded. It's supposed to work as follows: If you select "PayPal" with the radio button, the "Check" field should disappear. If you select "Check," the PayPal field should disappear. This is no longer happening. Can you help?

    Thanks.

    VZC

    Page URL:
    http://vermontzen.org/workshop_reservation.html

    registration form preview check select
  • Profile Image
    JotForm Support

    Answered by jonathan on March 20, 2014 at 06:59 PM

    @VZC

    Hi,

    Please correct the condition rules setup on the form. Use the images below for guidance

     

     

    Here is a test form http://form.jotform.me/form/40786777758477 where I had it corrected.

    Please inform us if you need further assistance.

    Thanks!

  • Profile Image

    Answered by vermontzen on March 20, 2014 at 07:29 PM

    Thank you. I will do that. However, that was the way I originally had it set up and it didn't work. I then changed it to HIDE the fields. Will go back to SHOW.

  • Profile Image

    Answered by vermontzen on March 20, 2014 at 07:51 PM

    Changed it as indicated, but it still doesn't work in Firefox and IE.

  • Profile Image

    Answered by Cesar on March 20, 2014 at 10:57 PM

    I have tested the changes on your form and they appear to be working properly both on IE11 and on FireFox 27.0.1. 

    Kindly try clearing your browser's cache and try your form again. If the issue persists and the form is embedded on a website, do try to embed the form using the iFrame Method

    Do let us know if the issue persists, Thank you.

    Screencast of my Test IE & FireFox:
    http://screencast.com/t/JihWkfS3h

  • Profile Image

    Answered by vermontzen on March 21, 2014 at 06:54 AM

    Thank you. I did clear my cache before contacting you and several other times while trying to get the form to work, but no luck. This morning, however, it is working as it should! Thank you for your help.

  • Profile Image
    JotForm Support

    Answered by jonathan on March 21, 2014 at 09:33 AM

    @vermontzen

    Hi, thank you for updating us about it.

    Contact us again anytime if you need assistance on JotForm.

    Thanks!