Stripe / Plaid ACH Form erroring

  • Profile Image
    CaputoDesign
    Asked on November 18, 2021 at 06:43 PM

    Hello,

    I am working on multiple ACH payment forms using jotform for a customer.

    example form:

    https://form.jotform.com/213215736743152

    I have double checked all api keys are set correctly, and the webook has been added to stripe per the ACH integration instructions. I am running in sandbox mode and have the sandbox keys in place.

    I can verify the bank with the sandbox user (user_good , pass_good)

    Once I put the submission in, it will error with:

    'oops! Must provide source or customer'


    Please advise.


    Thanks





  • Profile Image
    Girish
    Answered on November 19, 2021 at 12:34 AM

    Thanks for the information.

    Since you have done all verification, also checked the keys and IPN endpoint as correct, I can only assume that there is some issue connecting with the bank for sandbox testing.

    Could you check if you get the same issue when you connect the payment field on Development or Production mode?

  • Profile Image
    CaputoDesign
    Answered on November 22, 2021 at 06:19 PM

    I have updated to development, and am still encountering the same error. Please advise.

  • Profile Image
    Girish
    Answered on November 22, 2021 at 10:31 PM

    Please note that for each environment set up on the payment field, the API key, Client ID and Plaid secret key will be different.

    So please ensure that when you are using the Development environment, you are using the credentials for development and not for the sandbox. Upon checking your form payment field, it seems you are using the same sandbox creds for the development environment too.

  • Profile Image
    Girish
    Answered on November 22, 2021 at 10:32 PM

    Lastly, please reintegrate the payment field on the form - i.e. delete it and add a new one and then check.