What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form fields are missing after error popups when saving form

    Asked by templesinai on March 25, 2014 at 05:39 PM

    Greetings,

    I've been working on a form for may days now. It's been saved many times. I even made 2 test submissions to it.

    I was just putting the final touches on the form and clicked save and got an error message. Now the form is empty. NONE of the work I did is there and I can no longer even access the 2 test submissions that I created before. I even tried to access it from a different browser and that didn't work.

    Is there a backup of the form I can use. Will access "magically" appear for me if I wait an hour or so? Please help.

    The form title I'm working on is: "Family Shabbaton Retreat May 2014".

    Thank you,

    Mike Stombaugh
    Temple Sinai, Reno, NV
    775-747-5508
    admin@sinaireno.org

    Submissions form title message different
  • Profile Image
    JotForm Support

    Answered by Welvin on March 25, 2014 at 08:11 PM

    Hi Mike,

    Please try to check your form revision history. This guide: Introducing-Form-Revisions-Never-Lose-Your-Work-Again-. You should be able to see all the revisions made to your form, check for the recent updates you've made and then click "Revert to this version". You should be able to retrieve the whole form and the submissions.

    Please update us here for the results.

    Thanks

  • Profile Image

    Answered by templesinai on March 26, 2014 at 12:54 PM

    Thanks for the response. I checked my revision history. In it I can see where the latest version is blank and the versions before it are not.

    HOWEVER, when I choose one to revert to, and it confirms that the reversion has been applied (by displaying "revert completed," it STILL doesn't show up when I go to my forms and try to edit/open the form. It's still completely blank.

    I do like the POSSIBILITY of restoring from our revision history, but it's not working for me in this case. I would like to "revert" to the version of the form created at 2:21pm yesterday (March 25).

    I even tried this in both Chrome and Firefox (latest versions for Windows) and get the same results. Is there a "cache" somewhere that I need to clear? How do I do it? Thanks!

  • Profile Image

    Answered by templesinai on March 26, 2014 at 01:41 PM

    Here is a Jing screencast of the problem I'm having.

    http://screencast.com/t/gfYsmUfPy

    Thanks,
    Mike 

  • Profile Image
    JotForm Support

    Answered by Mike_T on March 26, 2014 at 04:17 PM

    It is probably that the form was not properly saved into the database, so that you received a corrupted blank version. I was able to revert your form back to the 11:21PM, March 25th version:

    I hope it helps. If you need any further assistance, please let us know. Thank you.

  • Profile Image

    Answered by templesinai on March 26, 2014 at 07:46 PM

    Thank you.