What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    The conditions of my form do not show/hide the fields specified

    Asked by swalther on March 26, 2014 at 08:50 AM

    Guys, your conditional formating rules are badly broken.

     

    Pleae have a look at my form: http://form.jotformeu.com/form/40842821370349

     

    There are 4 rules for the hardware field. Only the first rule works.

    How can this be fixed?

     

    Thanks!

    Page URL:
    http://form.jotformeu.com/form/40842821370349

    thanks jotformeu
  • Profile Image

    Answered by EliezerN on March 26, 2014 at 11:39 AM

    Hi

    Upon checking your form conditions I found that there was a condition conflict that's why your form does not work as expected.

    The cause is that you have setup two more conditions which are not needed. Those are the Hide conditions and conditional actions: 

    Since you already defined when the fields will be shown, that means that it the conditions are not met, those fields will remain hidden. So, as shown in the screenshot, you have to delete the Hide ruls and conditions. So, your conditions have to be this way:

    Then your form will work in this way (This is a cloned version of your form): http://form.jotform.co/form/40844364115855

    You can clone my for if you do not wish to do the changes to your form, here is how to clone forms: How to clone an existing form from a URL

    Inform us if you need further assistance with this inquiry.

    Thanks

  • Profile Image

    Answered by swalther on March 26, 2014 at 01:55 PM

    Wow.. thanks for the fast response!

     

    So indeed, I'm sorry, it was my fault.

    I reproduced the steps you suggested and it works exactly as it should be!

     

    Thank you very much! Great support guys! :)