Autoresponder sending every time on submit - error

  • Profile Image
    Hristova_Ivelina
    Asked on November 25, 2021 at 02:32 AM

    Hi, i have this form

    https://form.jotform.com/213277536078866


    Autoresponder "Email 1" is set to send on submit only and it has a condition that has to met. However, the email sends every time the form is submitted and is ignoring the conditions. If signatures are filled the Email 1 should not send. Autoresponder Email 2,3,4,5,6,7,8,9 are set up exactly the same way and have the same condition and are sending only once, However Email 1 sends every time the form is edited and re-submitted.

    Please advise

  • Profile Image
    Yau_C
    Answered on November 25, 2021 at 06:06 AM

    Please allow me some time to check. I will get back to you soon, thanks.

  • Profile Image
    Yau_C
    Answered on November 25, 2021 at 10:18 PM

    Hi,

    Please correct me if I am misunderstanding you.

    Your expect Email 1 to send only if

    • signatures (1-9) are empty
    • form is edited and re-submitted

    But email1 is sending even when some of the signatures are filled.


    This is your current settings:

    1637894886_61a04ae6e80e0_

    This is simply asking Jotform to send Email 1 (autoresponder) to {1Email} which is another email address field.

    It is not asking Jotform stop sending autoresponder Email 1 when some of these signatures are signed.


    I have cloned and tested your form: https://form.jotform.com/213277536078866

    1637894296_61a0489851480_

    I change the setting (in my cloned version) to the following:

    1637896173_61a04feda78e8_

    Thinking that these settings might be forcing autoresponder (Email 1) to override your conditional logic,

    and now it supposed to disable autoresponder (Email 1) and only send by conditional logic.

    But I received from autoresponder Email 1 even when signatures were empty as well as when signed.

    1637896137_61a04fc95da9c_

    I need to escalate this as a bug for our backend team to investigate.

    Our apologies for the inconvenience caused.

  • Profile Image
    Hristova_Ivelina
    Answered on November 25, 2021 at 10:49 PM

    awesome thanks.


    That is exactly what is happening Email 1 is sending regardless of conditions.

    Will wait your response.

  • Profile Image
    Jeric_T
    Answered on November 25, 2021 at 10:57 PM

    Hi there,

    Thanks for confirming!

    This has been raised to the backend team. While we don't have a specific ETA, rest assured our team is doing their best to resolve this the soonest.

    You'll be notified on this support thread of any development.

    Kind regards,