my paypal pro payment jotform isn't showing the credit card info iframe on my website & facebook

  • Profile Image
    hkmurano
    Asked on March 28, 2014 at 03:33 AM

    I can see fine within jotform but when I embed it on my website & facebook business page it doesn't show the same. In the Paypal pro payment option when I select credit card option and click submit button the credit card info input form gets cut off and show only the credit card first name & last name field in the form.

    Please check out http://golansky.com/payment.html & input 6 numeric number in the invoice number & any amount then select credit card option then click submit button. You'll see what I mean.

    Also same thing happens on facebook as well. Go to https://www.facebook.com/lanskyusa/app_128953167177144 and do the same as you'll see the same thing happening Don't know javascript well but I think it has something to do with that portion in the setheight or something. What do you think is the problem?

    Need assistance ASAP as this is in production live and causing problem for my customers to make a payment!!

     

    Thanks!

  • Profile Image
    TitusN
    Answered on March 28, 2014 at 05:25 AM

    Hello,

    For your website (http://www.golansky.com/payment.html)- try using this Iframe code which I have forced to adopt a height of 900px:

    <iframe id="JotFormIFrame" onload="window.parent.scrollTo(0,0)" allowtransparency="true" src="https://secure.jotform.us/form/40508341142140" frameborder="0" style="width: 100%; height: 900px!important; border: none;" scrolling="no"></iframe>

    For your Facebook page - use the same code, and adjust the HTML tab height to 900px

    Let us know if this helps.

    **

    It would be great if we could handle the Facebook page and the Webpage differently - please open a new support request for the Facebook Page by clicking this link.

    Thanks.

  • Profile Image
    Cesar
    Answered on March 29, 2014 at 12:46 PM

    Your response has appeared blank on your thread. If you are attempting to reply. please log in to your JotForm account and repost your response on thread: http://www.jotform.com/answers/354199. So we may assist you further.

    Thank you.

  • Profile Image
    hkmurano
    Answered on March 29, 2014 at 02:10 PM
    Thanks. It works. Initially had left out !important
    Sent from my iPhone
    ...