What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    SMS Confirmation Widget shows error

    Asked by movige on April 01, 2014 at 05:15 PM

    Hello,

     

    i have problem with SMS verification widget. please see form link and attached screen shot.

    allso i need help to change default country from US to Georgia if possible.

     

    thanks a lot for your attantion

    regards

    Page URL:
    http://form.jotform.me/form/40907051648455

    Screenshot
    problem sms verification form link change default
  • Profile Image
    JotForm Support

    Answered by EltonCris on April 01, 2014 at 06:23 PM

    Hi,

     

    Thanks for reporting and apologies for any inconveniences caused.

    I have now escalated this issue to our higher ups so they can check and investigate this. They will respond here once this is resolved.

    Regards!

  • Profile Image

    Answered by movige on April 02, 2014 at 01:47 AM

    thanks for replay.

     

    it's might be strange but now ther is another error with same form same link, i even not touched it. i just refreshed link and tested and got Authenticate error.

  • Profile Image

    Answered by cettox on April 02, 2014 at 03:08 AM

    Hi,

     

    There was several bugs causing this and similar problems on widgets, they all are now fixed. Please do following to see that error was fixed on your end:

     

    * try re-running SMS Confirmation widgets' wizard UI, by clicking the wand icon. This UI is where you set-up your Twilio auth information

    *If still having problems try removing question and re-adding it.

     

    Thanks.

  • Profile Image

    Answered by movige on April 02, 2014 at 04:14 AM

    thanks a lot. ti's working now. 

    one confusion, which i mentioned steel remaining. if u fix it i will very apprtiate :) i am speaking about default country code. there is no option to change it. is it possible to do that? i nedd to have Georgia +995 in stead of US +1 as default.

     

    thanks a lot for your attantion

    kind gerards 

    George

  • Profile Image

    Answered by movige on April 02, 2014 at 04:41 AM

    Ooopsss

     

    stell error of Authenticate :(:(:(

  • Profile Image

    Answered by movige on April 02, 2014 at 04:50 AM

    i fixed that this error Error : Authenticate appears when i use google chrome browser. can it be fixed? it's important a think. for internet explorer it's working. 

  • Profile Image
    JotForm Support

    Answered by EltonCris on April 02, 2014 at 07:03 AM

    @movige 

    Regarding on your other request, may we suggest you to post it on a separate thread to avoid confusions since this thread is about SMS widget glitch. Thanks for your understanding.

    --

    I have check again my test form made recently and it's working fine by now. Tested on both Chrome and IE browsers.

    I would suggest to delete your existing sms widget and create a new one. Enter your twilio credentials again and check. It should work in any browsers. Clearing your browser's cache will also help.

    Thanks!

  • Profile Image

    Answered by cettox on April 02, 2014 at 07:35 AM

    Hi,

    Error : Authenticate occurs when you setup sms widget in "US Only" mode, and try to send and sms to an outside US phone number. Try using it with an US based phone number, or suply your twilio account details for it to function properly world wide.

     

    Thanks.

  • Profile Image

    Answered by cettox on April 02, 2014 at 07:37 AM

    @movige BTW, your request on setting default country code is fantastic! Please submit a request as Elton suggested.

  • Profile Image

    Answered by movige on April 02, 2014 at 09:10 AM

    Dears,

     

    Twilio account i set up is internation for sure, there is no problem, the fact is that it works in Internet explorer.

    what is strange is that i triyed several PC in the office. for some PC it works on google chrome for some not. :)

     

     

  • Profile Image

    Answered by Carina on April 02, 2014 at 10:00 AM

    Can you provide us more details of the versions of the Chrome used?

    Thank you.

  • Profile Image

    Answered by movige on April 02, 2014 at 10:05 AM

    it's strange but both of them are the same

     Version 33.0.1750.154 m

  • Profile Image

    Answered by EliezerN on April 02, 2014 at 11:07 AM

    @movige

    Can you please let us know if you tried changing the setting in your widget from "US Only" to "International"? If not, please give it a try. That should resolve the issue.

    Kindly let us know if the issue still persists.

    Thanks

  • Profile Image

    Answered by movige on April 02, 2014 at 11:39 AM

    sure i did it but each time i open setting it is Only US but when i mark international my twilio data are there. 

  • Profile Image
    JotForm Support

    Answered by KadeJM on April 02, 2014 at 01:43 PM

    I tested this and I can confirm that this is a glitch with the widget so I would like to recommend that it be opened up as a New Thread in a separate issue as well even though it's related to the same widget.

    Test Video: https://shots.jotform.com/kade/Screenshots/2014-04-02_13h36_04.mp4