What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Bug - None of the conditions on the form are working at all

    Asked by ICA_Forms on April 03, 2014 at 09:15 AM

    On this form, when you select the "Reason for Arrival", the appropriate header paragraph is supposed to display. Currently the form displays all the header paragraphs, even when nothing is selected. There are several other conditions on this form, none of which appear to be working.  

     

    http://www.jotformpro.com/form/33285140639960?studentFirst=Grant&studentLast=zzzSchmitt&parent=techhelpdesk@interlochen.org&studentid=00000000&reasonFor3=Winter%20Break%20Arrival

    Here is a shortened version of the URL: http://goo.gl/FTy7TK

    parent selected www select
  • Profile Image
    JotForm Support

    Answered by KadeJM on April 03, 2014 at 11:02 AM

    I can see what you mean by that. All this was working before I take it? At first I thought maybe there was a conflict but now I am highly convinced it's a bug since I ran a new test via an entirely separate form just to check the conditons usage and it's working. However, When I started checking everything on your form I found you have several conditions and NONE of them are working after testing it.

    There is definitely something wrong here and we do apologize about that. I've now opened up a bug report about this to inform our dev's about this problem so that they can take a deeper look into the issue. As soon as we know something more about it we'll let you know.

  • Profile Image

    Answered by ICA_Forms on April 03, 2014 at 11:23 AM

    Yes, this was working before sometime midday yesterday. I was entering translations on this form and things suddenly stopped working.

  • Profile Image
    JotForm Support

    Answered by KadeJM on April 03, 2014 at 12:37 PM

    Thank You for the clarification about that. I will go ahead and update my notes to our devs about this.

  • Profile Image

    Answered by ICA_Forms on April 04, 2014 at 02:09 PM

    Looking for an update on this ticket. Haven't heard anything in about a day and it's negatively impacting us pretty heavily.

  • Profile Image

    Answered by EliezerN on April 04, 2014 at 03:29 PM

    @ICA_Forms

    We are really sorry for the time this is taking to be resolved. We have not received any update from our dev team yet. It is sure they are still working to find a solution as soon as possible. Once this is resolved we will update you via this thread.

    Thanks for your patience

  • Profile Image

    Answered by ICA_Forms on April 07, 2014 at 10:09 PM

    FYI, this form was reverted back to a previous version as a fix to a different ticket, and now is working. It was related to adding a translation.

  • Profile Image

    Answered by Cesar on April 08, 2014 at 12:59 AM

    Thank you for the input. Do let us know if you need further assistance. Thank you.