Check box conditions are not working

  • Profile Image
    wadecarpenter
    Asked on April 07, 2014 at 03:46 PM

    I am trying to set show/hide condtions for each check box on my form.  As you can see from the screenshot of the opened conditions wizard only one checkbox id is showing as available to set non of the other check box options are showing in the drop down list.

     

    Please advise,

    Thank you!

  • Profile Image
    abajan
    Answered on April 07, 2014 at 05:50 PM

    I believe there's been a misunderstanding of how the conditions wizard works. Conditions are set on fields as a whole and all 16 of the checkboxes in your form are contained within a single field. The ID to which you referred is actually that of the entire field and not of any single checkbox. (If that field were labelled, the label would be shown in the wizard's selector instead of "checkbox field(id75)".)

    So, the way to go about setting up the conditions would be something along the lines of "If checkbox field(id75) is equal to History, show History":


    Such a condition would show the "History" form collapse when "History" is checked in the checkbox field. What condition or conditions were you intending to create? Perhaps we can help you with them.


    Thanks

  • Profile Image
    abajan
    Answered on April 07, 2014 at 05:54 PM

    The above condition has been applied to this clone of your form. Please feel free to clone it and examine the condition.

  • Profile Image
    wadecarpenter
    Answered on April 07, 2014 at 06:30 PM

    Perfect!  Thank you very much for your help.