Is there minumum recommended browser levels for people filling out the forms?

  • Profile Image
    Brian Robilotta
    Asked on July 28, 2011 at 12:31 PM

    We want to ensure that all of our constituents are able to fill out a form we create in JogForm, and we were just wondering if there was a minimum recommended browser, or any other known browser issues with the form. Obviously, javascript must be enabled, but other than that?

     

    Thanks in advance for your answer.

  • Profile Image
    brx250
    Answered on July 28, 2011 at 10:51 PM

    Hi Brian,

    First of all, thank for using JotForm.

    Any modern browsers should do. But one thing you have to make sure is that customers using IE should use the latest version. However, as long as your customer has a browser that is javascript capable, in most cases, that should be fine.

    If you have any other questions, please feel free to contact us.

     

    _____________________________________________
    Albert JotForm Support