Cannot create an account

  • Profile Image
    jmccarthy0319
    Asked on January 13, 2022 at 02:02 AM

    I am unable to create an account to save a grant application for the Northwest Dayton Partnership. I have tried using my agency email and a password, my Google email, and my Facebook account. I receive an email from Jotform asking me to verify my email address. However, each and every time I click on the orange verify email button, I receive the message "Unauthorized Access You need to login as 'jmccarthy0319@gmail.com'. You are logged in as:" However there is no information about who the system thinks I am logged in as.

    The one time I think I was successful, I then went to the application, and tried to save it, only to receive an error message that said "An error occurred, please check your internet connection."

    If I close everything out and start over, when I attempt to save the grant application and use my Google email to access Jotform, I then receive the message that is in the screenshot attached.

    Screenshot
  • Profile Image
    Norwyn_E
    Answered on January 13, 2022 at 05:13 AM

    Hi there,

    Hope all is well.

    I see here that you already have an active free subscription thru this email - jmccarthy0319@gmail.com. Are you trying to fill a form? If yes, please send us the link to the form so we could do a test on our end. In the meantime, please try to log in via this page and then try to access the grant application you need to save.

    Looking forward to hearing from you.

  • Profile Image
    jmccarthy0319
    Answered on January 13, 2022 at 08:11 AM
    Thanks for your email. No luck with that page. The place in the application
    where I want to save is located at the link below:
    https://cdn.jotfor.ms/amy.jomantas/northwest-dayton-partnership-applic
    *Jim **[he | him | his] Why Pronouns?
    *
    *Jim McCarthy*
    *Dayton, OH*
    *jmccarthy0319@gmail.com *
    ...
  • Profile Image
    Gilbert_P
    Answered on January 13, 2022 at 08:41 AM

    Hello,

    I cloned the form and wasn't able to replicate the issue. I opened the form on my browser's incognito mode, filled out some fields then saved the form, and I received the saved form email after I logged in to my Jotform account.

    Please try clearing your browser's cache and cookies, log in to your Jotform account on this page, then save the form again.

    Let us know how it goes.