Renamed columns in tables revert to originals on close.

  • Profile Image
    ckemmann_pwi
    Asked on January 13, 2022 at 02:01 PM

    Hi,

    When I rename columns in my table according to these User Guide instructions, the changes work up until I close the table. When I reopen the table, the column name reverts back to the original name. I even tried changing the question name in my form, thinking that at least it would revert to that, which would solve my problem.

    That isn't happening. When the column name reverts, it reverts to the original question name from when I originally created it for the form. If I change the name, and then switch the table type to say Cards, it also reverts the name. When I change back to the table type, it is also reverted there.

    Any help resolving this issue would be greatly appreciated, thank you!

    Chris K.

  • Profile Image
    igorbojczuk
    Answered on January 13, 2022 at 06:33 PM

    Hi Chris,
    Thanks for reaching out to Jotform Support.
    We have tested multiple times tables on your account and could not replicate your error. Would you be able to:

    We suspect this might be a network error, the change is not received by our server.

    Looking forward to your reply, and we would like to apologize for this inconvenience.

    Kind Regards,


  • Profile Image
    ckemmann_pwi
    Answered on January 17, 2022 at 09:12 AM

    Hi Igor,

    I followed the steps you recommended, and I can confirm the changes work in incognito mode, but not in the regular browser. Here's a screen recording of the console you requested, in action as I attempt first to refresh the table page, and then to rename the column in question.

    1642428582_61e578a66bce2_Animation.gif

    This is a screenshot of the specific error that occurs when I try to rename the column:

    1642428722_61e5793203c32_

    Chris

  • Profile Image
    Kenneth
    Answered on January 17, 2022 at 11:42 AM

    Hi there,

    Can you share with us the Column names you changed so we can try to replicate the issue?

    Or does it occur on all columns?

    And can you share the browser that you used where the issue occurred as well?

    Awaiting your response.

    Best.

  • Profile Image
    ckemmann_pwi
    Answered on January 17, 2022 at 12:47 PM

    The column names are Equipment, Work Type, and Issue Type. They were formerly random textbox names, and when I wasn't able to change them in Firefox I changed them in Microsoft Edge.

    I can confirm I have the most up-to-date version 96.0.1 (64-bit) of Firefox installed. Aside from this issue and the one described in this question, Jotform works for me without issue on Firefox. In that other question, clearing the cache fixed the issue, here it does not.

    Edit:

    I can confirm that this issue happens in all columns that I've tested, not just those three.

  • Profile Image
    Marco
    Answered on January 17, 2022 at 03:24 PM

    Hello there,

    Thanks for reaching out to us.

    I tried to update one of the columns on your table:

    1642450907_61e5cfdb2b9bc_

    Could you kindly let us know if the name reverts back to Equipment on your end?

    You may try to follow the steps on this video. It's a workaround that works when the order of the columns doesn't reflect the order of the form fields, but you may try to use the same workaround also for the glitch you're experiencing:

    https://drive.google.com/file/d/1miswTCRPmqz5MUgJKvBxRJMWBaew0eeo/view

    We'll be waiting for further information,

    Regards

  • Profile Image
    ckemmann_pwi
    Answered on February 01, 2022 at 02:14 PM

    Marco,

    The name will not revert back unless I use private mode or another browser. The video tutorial unfortunately did not help with the matter. The issue is the same as before, I cannot rename Jotform columns in Firefox.

    Chris

  • Profile Image
    Marco
    Answered on February 01, 2022 at 03:53 PM

    Hello there,

    Thanks for your further details.

    We can't seem to be able to reproduce the glitch on our end.

    If the issue doesn't occur in incognito mode, I can only think that your browser cookies and cache have not been fully deleted.

    Can I ask you to make sure to specify Everything on the Time range to clear setting?

    1643748661_61f99d35234de_

    Let us know if the issue still occurs.

    Thanks for your cooperation,

    Best

  • Profile Image
    ckemmann_pwi
    Answered on March 16, 2022 at 11:14 AM

    Marco,

    Sorry it's been a while. I just recently tried to rename a column again after a recent Firefox update, and I can no longer reproduce the issue. I believe it must have been a problem with my local Firefox install. Regardless, I am now able to rename column headers without issue. Thank you all again for your help.