What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    The "Form collapses" of my forms are not working, they do not open

    Asked by magnatexforms on April 24, 2014 at 04:57 PM

    Randomly checking on form page and notice that the click here to expand and access the forms is not working for me. Checked on another computer in the office to make sure it wasn't just me, it wasn't/it isn't. Refreshed, republished, etc. Not sure what the problem is. Last submission was yesterday so it was working. Thanks for help.

    Page URL:
    http://www.magnatexpumps.com/quoteform.html

    expand problem office checked
  • Profile Image

    Answered by EliezerN on April 24, 2014 at 06:28 PM

    I was able to reproduce the issue while checking the form here: http://www.magnatexpumps.com/quoteform.html

    However, upon inspecting the source  code of your form I foun that you have two forms in that same page, both of them are embedded using the Embed code, which probably is causing a scrip conflict between both forms and that's the reason why the Form Collapse are not working properly.

    So, in order to resolve this issue, please re-embed your forms using the iframe code at this time, here is how to get the iframe code: Getting the form iframe code

    That should resolve the issue.

    Inform us if you need further assistance wtih this query.

    Thanks

  • Profile Image

    Answered by magnatexforms on April 24, 2014 at 07:05 PM

    The iframe embed option does not work properly. It is on the site now for you to see, moved it to this page: http://www.magnatexpumps.com/quoteformtest.html. In addition, with the form collaped, it still includes all of the empty white space that the form will take up when expanded.

  • Profile Image
    JotForm Support Manager

    Answered by Jeanette on April 24, 2014 at 11:02 PM

    I am able to see two forms embedded in your page using the iFrame version

     

    I would recommend you to use another method for one of those. For example, you can make an HTML button that would redirect to another webpage where one of them is embedded. And leave only one on that page

    An html button with redirect to another page, could be this one (you would have to replace the URL in the ACTION by the form URL and the value by something like "Click here to request a phone call"

    <form action="http://google.com"> <input type="submit" value="Go to Google"> </form>
  • Profile Image

    Answered by magnatexforms on April 25, 2014 at 08:59 AM

    The original way I had it works fine now. The difference being that yesterday upon inspect element the jotform javascript files were not loading. Today they are. So hours of going in circles and redoing forms for pretty much nothing. The forms on the page have been working correctly for MONTHS and then not yesterday and I only know becuase I am randomly linking to that page and now they work again today. 

    http://www.magnatexpumps.com/quoteform.html

    Guess that is just the way it is. Even though they didn't work, I appreciate the suggestions and help. Glad the original way is working.

  • Profile Image
    JotForm Support

    Answered by KadeJM on April 25, 2014 at 10:19 AM

    I also did a test of this via your form collapses and I didn't find any such issue and as far as I know we haven't had any problems of that sort for awhile now. But there is the possibility of one of our updates may have caused a temporary problem that was fixed shortly after. It also very well could have been a small issue in your browser with the javascript used to run it. Either way though, we're glad to see and hear it's working again for you now.

    Video Test: https://shots.jotform.com/kade/Screenshots/2014-04-25_10h07_01.mp4