Form background way too large when in Safari

  • Profile Image
    Swags
    Asked on August 01, 2011 at 09:46 AM

    Hello,

    I have created a form that has a lot of "Show/Hide a Form Field" conditions.  The form has a grey background and right when the page loads the form displays all the fields on the form, even though the conditions tell the form to hide those fields.  This does this all the time no matter what browswer I am on.  The real problem is when the pages are viewed on Safari.  The form immediately expands upon page load but a second later, just like in all other browsers, the form hides all of the fields that should be hidden.  However, in Safari, the background stays the size that it was when all the fields were showing. This background is covering up important material on my webpage that my customer needs to be able to see in order to make their form selections.  This is not a problem in firefox or IE, not sure about chrome, but it a huuuge problem in sarari.  How can i fix this?

     

    Thanks!

    Taylor

  • Profile Image
    NeilVicente
    Answered on August 01, 2011 at 08:03 PM

    Hi,

    I tested your embedded form using Safari for a couple of times but failed to replicate your problem. The form behaves uniformly across all browsers. Below is a screenshot of the embedded form in your page under Safari (Windows):

     

    Obviously, since the form works perfectly fine on my end, we can cross out the form and its embed codes being the culprit in this issue. Have you tried resetting your Safari browser? If not, please do, then let us know the results.

    We will be looking forward to your updates. Thank you for using Jotform!


    Neil

  • Profile Image
    Swags
    Answered on August 02, 2011 at 11:49 AM

    I have actually solved the problem.  At the beginning, I was simply using the script tag instead of the complete source code.  This caused the entire form to flash really quickly at the beginning before condensing to it's conditioned state.  Since I got rid of the flash, I also got ride of the background problem as well.  thank you

  • Profile Image
    allanftd
    Answered on August 02, 2011 at 12:26 PM

    Glad that you figured it out well, Swags. Please let us know if you need further assistance!

    Thank you for using JotForm!

    JOTFORM SUPPORT