Fields are not conditionally hidden

  • Profile Image
    a2derbydimes
    Asked on August 02, 2011 at 04:47 PM

    Hello,

    I created a form at http://www.jotform.com/form/12135720029 with four show/hide a form field conditions, but when I go to the URL to make a test submission to the form, the conditions don't seem to be working. Can you advise why this is happening? The people who will be completing the form are very web-unsavvy, so it would really help for the show/hide conditions to work so that the users give me all of the information I need.

    Thank you!!

  • Profile Image
    NeilVicente
    Answered on August 02, 2011 at 05:11 PM

    Hi,

    You have redundant conditions in your form, that is why the fields are not showing/hiding. If you have configured a field to show when a certain condition is met, surely it would not show (i.e. hide) when that condition is not met, right?

    Hence, there is no need to create conditions to hide them. Delete the two useless conditions in your form to make it work perfectly.  Proof is this clone of your form.

     

    Let us know if you have other questions. For more information regarding conditions, please visit the link below:

    Conditional Logic in Forms


    Neil

  • Profile Image
    a2derbydimes
    Answered on August 02, 2011 at 05:13 PM

    Thank you! I had it in my head that I had to have conditions for either response.

  • Profile Image
    NeilVicente
    Answered on August 02, 2011 at 05:15 PM

    You're very much welcome. Glad to know I was able to help!