What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Conditional emails are not working on my form

    Asked by shannonhawkins on May 14, 2014 at 07:39 PM

    I have set up all my auto-responders and have made my conditionals. When I first created this form I ran test emails and all the conditionals were working as intended. Now, when I fill out the surveys as a test run, the conditinals/autoresponders are not working for any of the options I select. What could be going on?

    Page URL:
    http://www.jotform.com//?formID=41284505965157

    Emails conditional emails fill autoresponders select
  • Profile Image
    JotForm Support Manager

    Answered by Jeanette on May 14, 2014 at 11:26 PM

    Checking deeper, I see you have setup a custom Sender Email. Is nsg*******tics@wgu.edu bein handled by google apps? Can you please confirm my hunch? For if this is the case, they might had set filers to block our servers.

    Nevertheless, to solve the problem you might probably want:

    To change sender email to noreply@jotform.com or noreply@formresponse.com

    -Or if you want to keep using the custom email address as your sender email, please use the Mandrill service instead.

     

  • Profile Image

    Answered by shannonhawkins on May 15, 2014 at 11:51 AM

    The sender email comes from my Outlook account affiliated with the university I work for. If your hunch was that it was setting filters to block the Jotform servers, then why do all of my other survey/quizzes seem to work just fine? I get all of my autoresponder/conditionals to work well for them.

  • Profile Image

    Answered by shannonhawkins on May 15, 2014 at 12:01 PM

    I also just changed the sender email to noreply@jotform.com and it still did not work :(

  • Profile Image

    Answered by Carina on May 15, 2014 at 03:29 PM

    I checked your form and the conditions have the wrong ID assigned:

    In the conditions you have {wguStudent} instead of {wguStudent4}

    If assigning the correct ID the conditions should work properly.

    Please let us know if the problem persists.

    Thank you

  • Profile Image

    Answered by shannonhawkins on May 15, 2014 at 03:53 PM

    That field pre-populated itself. Where/how would I know to change it to {wguStudent4}? I need to understand the logic behind where that "4" comes from so that I can understand this for future reference. 

     

  • Profile Image

    Answered by Carina on May 15, 2014 at 04:03 PM

    A field ID is automatically created according to it's name and a number is assigned so that each ID is unique even if more fields have the same exact name. If for instance a field is deleted and a new one is added, the field's ID changes, hence the 4. To use this kind of conditions that allow you to send an email to specific address according to the user's choices it is necessary to use the correct field ID. To find out or confirm a field's ID please select the field>properties:

    Let us know if further support is needed.