What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Edited records not updated in Google Spreadsheet

    Asked by oaerdts on May 25, 2014 at 06:57 AM

    Hi,

     

    have an integration with both Google Docs and Google spreadsheet.

    New entries in the form are created in both Docs and spreadsheet.

    But when editing the form (via edit link), a new do is created in Docs, but the spreadsheet is not updated.

     

    Any clue how to solve?

     

    Oscar

    Page URL:
    http://forms.etwha.de/form/41435364418353

    Updated edit link and spreadsheet
  • Profile Image

    Answered by bob on May 25, 2014 at 10:19 AM

    We are extremely sorry for the inconvenience.

    I have forwarded this particular issue to our developer team. They will look into the matter and update us whenever they reach to a solution.  

    Thank You

  • Profile Image

    Answered by oaerdts on May 25, 2014 at 11:49 AM

    Thk for the quick reply bob.

    let me know if you need any more details (like shared google docs)

     

    Oscar

  • Profile Image

    Answered by BryanPaulo on May 25, 2014 at 01:42 PM

    Hi Oscar,

    Have you tried re-integrating your google spreadsheet? Please disconnect then try to reconnect:

    Once removed, please try to integrate then test your form and check if new data will be added to your spreadsheet.

    Update us with the result.

  • Profile Image

    Answered by oaerdts on May 26, 2014 at 05:28 AM

    hi BryanPaulo,

    thx for your reply.

    Removed the integration, reconnected and new spreadsheet is polulated with currect (edited) entry.

    Changing that entry is (again) not populated to the google spreadsheet.

     

    it's not a dealbreaker for me, as I can download all entries from Jotform in a spreadsheet aswell. Or I could remove-reconnect the integration from time to time.

    But since Integration is available, I think it should not only interface new entries, but also changed entries...

     

    Oscar 

  • Profile Image
    JotForm Support

    Answered by ashwin_d on May 26, 2014 at 08:50 AM

    Hello Oscar,

    I did just created a demo form and integrated it with my google spreadsheet account. I just clicked on the edit link of the submission email I received and it did update the specific google spreadsheet record. It seems to just work fine. 

    Please test the following form URL:  http://form.jotformpro.com/form/41453072751955?

    Integrated google spreadsheet:  https://docs.google.com/spreadsheets/d/1O2fA1ClXjKDl_wEDSAZlZrxzalX2vcoT4g24MckNWww/edit?usp=sharing

    Is it possible for you to share the google spreadsheet URL with the permission so that we can take a look and try to replicate the issue you are having.

    We will wait for your response.

    Thank you!

  • Profile Image

    Answered by oaerdts on May 26, 2014 at 10:21 AM

    Hi Ashwin_d,

     

    thx for your reply.

    Can't really test, since I can't edit the entry (no edit link).

    Spreadsheet link is:
    https://docs.google.com/spreadsheets/d/1xfv0uTmFXIhjdm-ToqWmLXa5-ZgcYGbd6ZCYKd7zeUE/edit?usp=sharing

    Data is all testdata ;)

     

    Oscar

     

  • Profile Image
    JotForm Support

    Answered by Welvin on May 26, 2014 at 10:46 AM

    Hi Oscar,

    If you look at the spreadsheet. I was able to submit to your form and change the data on it. As you could see, it is now updated.

    I used the following edit URL: http://forms.etwha.de/form.php?formID=41435364418353&sid=266823724901324989&mode=edit.

    So, I think it's just a temporary issue. Please try it again and let us know for the results - if the spreadsheet will be automatically updated this time.

    Thanks

  • Profile Image

    Answered by oaerdts on May 26, 2014 at 02:33 PM

    Hi Welvin,

     

    Thx for your effort but I can't reproduce it.

    Deleted entries, reconnected integration and started all over.

    Same result, new entry in google docs but changes not populated to the spreadsheet.

    What majic tric did you do?

     

    By the way: the edit URL you mentioned is NOT the URL in the notification.

    Is it normal behavior that after submission, I get a notification but the user doesn't? he does when it's a new entry...

    ** Got the answer, yes, it's normal behavior, to be solved by notification to user **

    Oscar 

  • Profile Image
    JotForm Support

    Answered by Mike_T on May 26, 2014 at 03:19 PM

    The Google Spreadsheet is supposed to update entries automatically, so there might be some issue related to specific form.

    I have submitted your form, and then updated my submission using the following link from email alert:

    http://submit.jotformeu.com/form.php?formID=41435364418353&sid=266940663674345203&mode=edit

    Please check the spreadsheet to see if it was updated.

    Thank you.

  • Profile Image

    Answered by oaerdts on May 26, 2014 at 03:47 PM

    Hi Mike_T,

     

    Your initial form was interfaced to the spreadsheet (the one with original)

    The editted version (the above in your post) is NOT updated in the spreadsheet.

    The are populated to Docs

    https://drive.google.com/folderview?id=0Bzb-OMVAbcSadHZsVUtIUTltOFk&usp=drive_web

     

    Oscar 

  • Profile Image

    Answered by EliezerN on May 26, 2014 at 04:22 PM

    @Oscar

    Thanks for the confirmation. It is clear that there is an issue with the Spreadsheet integration not updating entries when a submission is edited.

    Have you tried to reproduce the issue with a different form? Maybe with a cloned version of your current form? If not, please give it a try. That would throw different results.

    Kindly clone the form in question, here is how: Form cloning

    Then, build the integration and make tests.

    Kindly let us know if that makes a difference.

    By the way, our next level support is still working to resolve this issue, so you will be updated by them sooner than later.

    Thanks

  • Profile Image

    Answered by oaerdts on May 28, 2014 at 04:12 AM

    Hi EliezerN,

     

    Started from scratch with a new form, new intergartion Docs/Spreadsheet. It worked, but only ONCE.

    I've read about illegal charactars might cause the issue. What characters are to be avoided?

     

    Oscar

  • Profile Image
    JotForm Support

    Answered by jonathan on May 28, 2014 at 04:33 AM

    Hi Oscar,

    I assume this is the new form http://www.jotformeu.com/form/41456539938367

    the illegal character you have read were suppose to be the #,&, /` or some foreign language character when use in form field's name/label. BUT this should not be the case anymore as that restriction had been fixed already. And from what I checked on your forms, you did not used this characters in any field label/names on your form.

    Actually, the issue of the spreadsheet not being updated after doing EDIT submissions action was a bug.

    A ticket report about it was already submitted and now assigned to one of our developer.

    We will notify you on this thread for any progress update when available.

    Thank you.

  • Profile Image
    JotForm Support

    Answered by alp_deniz on May 30, 2014 at 04:25 PM

    Hello,

    Thank you very much for notifying us about the problem. As it is found out, the issue was related to empty labels, which caused update to crash when present. 

    Eventually the issue is fixed, you may now use edit/update feature. Please let us know if we can help you further.

    Kind regards

  • Profile Image

    Answered by Lifelongtherapy on October 21, 2014 at 09:43 AM

    Hi, I'm having this similar issue, the revision did work correctly in my spreadsheed, but not one the Google Doc.

    Most important is the spreadsheet so that is good.

    The revision did create a new google doc but it didn't reflect the changes in the doc.

    Has there been any update or work/around?

  • Profile Image
    JotForm Support

    Answered by Charlie on October 21, 2014 at 10:49 AM

    Hi Lifelongtherapy,

    This is a much older thread, I've opened a new thread for your specific concern. Please refer to this link for the updates http://www.jotform.com/answers/446669.

    Thank you.