My Forms were not loading correctly.

  • Profile Image
    PerAndersson
    Asked on June 15, 2014 at 09:59 AM

    This is bizarre. Is there actually any possibility of getting into contact with a live person at Jotform?

    My account does not work, "My forms" are not accessible. The screen looks like the enclosed picture. Totally useless. And I pay for it, I shall add.

    It there any person out there who knows where i can turn to in order to get this fixed.

    Dear "user community", thanks in advance for your help.

    BR, Per from Sweden

  • Profile Image
    BryanPaulo
    Answered on June 15, 2014 at 03:15 PM

    Thank you for contacting us.

    Unfortunately, we do not have phone support yet. We can help you by posting your concern here in oour support forum.

    Looking at your screenshot, looks like the CSS was not loaded properly. Can you try to reload the page and see if that fixed the problem? If it's still the same thing, can you try other browser? If it is isolated to a single browser, please tell us the version of the browser you are using.

    Do get back to us if you still need our assistance.

  • Profile Image
    PerAndersson
    Answered on June 15, 2014 at 04:48 PM

    Thank you for your response.

    I have tried Safari 7.0.3, Firefox 8.0.1 and Chrome 36.0.1985.67 - all give the ame result. The page "My forms" does not work. Everything else on the Jotform-site seems to be ok.

    Anyone have a clue?
    BR Per

     

  • Profile Image
    EliezerN
    Answered on June 15, 2014 at 05:39 PM

    @BR Pre

    Thanks for the information.

    I can see that you have opened multiple threads about this same issue.

    We have been giving you follow up on this thread too: http://www.jotform.com/answers/391877

    I kindly ask you to use that thread only in order to avoid confusions and in order to five you a more efficient assistance.

    Thanks for your understanding and cooperation.