What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Forms Are Not Submitting

    Asked by RescueOneSPFD on June 16, 2014 at 03:56 PM

    Hello -

     

    I have three forms on a client's website that previously have worked just fine but all of a sudden are not submitting.  The submit button switches over to "Please Wait" and then sits there forever.

     

    The three forms:

    http://rescueonespringfield.com/animal-surrender-form/

    http://rescueonespringfield.com/adoption-application/

    http://rescueonespringfield.com/become-a-foster/

    please wait hello all then
  • Profile Image

    Answered by bob on June 16, 2014 at 05:26 PM

    My first attempt with testing the form(1st one) worked just fine, that means the submit button functioned perfectly without showing "please wait..." message.

    Sometimes this type of problem occurs due to script conflict. To avoid this, you can try iframe embed code. Since your form is called inside an iFrame, it doesn't conflict anything on your page.

    Please get back to us with updates about your query.

    Thank You.

  • Profile Image

    Answered by RescueOneSPFD on June 16, 2014 at 06:55 PM

    Weird.

    Thank you for your prompt response.  i am still having the issue on my end as well as my clients on their end. Currently I am using the Wordpress plugin to quickly embed their forms.  You think I should directly embed the iframe code instead?

    -----------------------------------

    UPDATE:  I switched the codes to iframe and all of the forms seem to be working fine.  A pity that I must do this rather than use the Wordpress plugin, but at least they are now all working!  Thanks!