Form Not Working

  • Profile Image
    lanrete58
    Asked on June 17, 2014 at 04:36 PM

    Hello,

     

    It weird but Ive been having alot of people fill out my form and they say its not working. But when I go to my website and fill it out myself, it works. Im not sure whats going on.

  • Profile Image
    david
    Answered on June 17, 2014 at 05:37 PM

    Hi,

    I have cloned your form and tried it in a few different browsers and everything seems to be working fine.  I receive the submission data and then get redirected to:

    I checked your account limits also and you are getting close to your limit for bandwidth for the month but still have about 40mb left so that should not be an issue either.  If you could ask your users what error they are receiving that would help us look into your issue further.  Is there an error message, does the form just stall out after hitting the "submit" button, things of that sort.  Let us know and we will be happy to look in to it further.

    Thank you for using Jotform!

     

  • Profile Image
    lanrete58
    Answered on June 18, 2014 at 12:05 AM

    Thanks for your reply!

     

    Yes i know its weird I try it and it works fine! But Ive have four people try it and all dont work. They say it doesnt take them to the thank you page. One person says it says "Please wait" and the others I believe it does stall on them, where they hit submit and it just takes doesnt do anything. I tried it on a mobile device and it gave me an error message. I have of photo of what it says but I am not sure how to post it here.

     

  • Profile Image
    Welvin
    Answered on June 18, 2014 at 02:55 AM

    Hi,

    You can upload a screenshot to our support forum by following this guide: http://www.jotform.com/answers/277033.

    Probably a conflict is causing this issue, especially, you are using Wix website. Please re-embed your form using our iFrame Method: -Getting-the-Form-iFrame-Code. Since the form is placed inside an iFrame, this should create any conflict to the page.

    Thanks

     

  • Profile Image
    lanrete58
    Answered on June 18, 2014 at 03:26 AM

    Thank you . Here is the image.

  • Profile Image
    Welvin
    Answered on June 18, 2014 at 03:45 AM

    Thanks for the screenshot. Well, I think I am right that a conflict is causing this. Since the validation should suppose to takes place inside the form while it is not yet submitted. Please re-embed your form using our iFrame method to fix that.

    Thanks