Textbox hidden based on a condition are not visible while editing the submission even though the textbox has correct value.

  • Profile Image
    VCE
    Asked on June 18, 2014 at 09:02 AM
    Here are the issues I'm having. 

    I fill out the form mentioned above that contains conditions to show fields when other fields are populated. I receive an email with an "edit submission" link in it. When I click the link, the form opens in IE8. The trigger fields are populated but the conditional ones are not visible.

    If I change the selection in the field and then change it back the other fields appear. 

    If I resubmit the form without changing anything, the fields that haven't displayed do not show up in the email. 

    The latest issue is, if I open the form in IE8 and turn on compatibility mode, the form fields are unable to be entered - this isn't a big issue for me. I just won't turn on compatibility mode.

  • Profile Image
    ashwin_d
    Answered on June 18, 2014 at 09:14 AM

    Hello VCE,

    I believe I have understood your issue now.

    It seems the form conditions are not being triggered automatically if the field already has correct value. I created a simple demo form with conditional fields and I am able to replicate the issue you are having.

    I am reporting this to our back end team. We will get back to you as soon as we have any update from them on this issue. 

    Thank you!

  • Profile Image
    VCE
    Answered on June 25, 2014 at 04:57 AM

    Hi,

    Is there any news on this bug please?

  • Profile Image
    Welvin
    Answered on June 25, 2014 at 09:55 AM

    Unfortunately, there's no update yet. The report is already assigned to our developers. Our developers would update you here once this get fixed.

    Thank you for the kind understanding and patience!