changed form field name not showing values in emails

  • Profile Image
    dstart
    Asked on July 16, 2010 at 07:58 AM

    i have a form field(s) i need to edit in order to use a total script found here:

    http://www.mcfedries.com/JavaScript/OrderTotals.asp

     

    the jotform generated field name is:

    name="q1_set_3.50"

     

    the script needs the form field name to begin with  PROD_ as the first chartacters:

    name="PROD_q1_set_3.50"

     

    once i put PROD_ in front of the jotform generated field name, the field value no longer show up in my emails. ???(but DO show up in submissions and in reports)

  • Profile Image
    aytekin
    Answered on July 17, 2010 at 02:22 AM

    You can try changing this code

    if (form_name.substring(0,4) == "PROD") {

    To this:
    if (form_name.substring(0,1) == "q") {

    Then it would calculate all questions.
  • Profile Image
    dstart
    Answered on July 19, 2010 at 02:35 PM

    but why is it that the email notification or email responder do NOT include the values?

     

    (yet the reports and sumbmissions do show the values)

  • Profile Image
    aytekin
    Answered on July 19, 2010 at 03:15 PM

    Do not change the field names on the form. If the change them they will not be included in the emails or saved in our database. You should only change the javascipt code as described above.

  • Profile Image
    dstart
    Answered on July 19, 2010 at 03:18 PM

    not true. database DOES safe values.

     ONLY the email do not show filed values.

  • Profile Image
    aytekin
    Answered on July 19, 2010 at 03:19 PM

    Then delete the email and re-create it.

  • Profile Image
    dstart
    Answered on July 19, 2010 at 03:21 PM

    i did that too...recreate the email after changing the field name...still EMAIL did NT work... but database DOES work.

  • Profile Image
    aytekin
    Answered on July 20, 2010 at 02:38 AM

    If you test the form alone without any changes you made. Just the http://jotform.com/form/111111... Does the emails include all values correctly?