fields do not stay within the form border

  • Profile Image
    jkadwa
    Asked on June 26, 2014 at 06:45 PM

    Hi

     

    I have created quite a long form and I'm not sure why certain fields do not stay within the border of my form. this also affects formatting on the form.

    please see the screen shot attached but the authorisation heading and anything below is affected. I have tried to delete these fields and re enter them but it doesn't seem to work.

  • Profile Image
    ashwin_d
    Answered on June 26, 2014 at 11:23 PM

    Hello jkadwa,

    I am not sure if I have understood your question correctly.

    I did check the screenshot you have shared. Do you mean to say that the "Authorisation" section is not being aligned properly?

    Have you solved this problem already? I did check your form in chrome and firefox and it seems to  display the "Authorisation" section correctly. Please check the screenshot below:

    I would suggest you to please test it again and get back to us if the issue persists.

    Thank you!

  • Profile Image
    jkadwa
    Answered on June 26, 2014 at 11:34 PM

    hi

    as you can see in my screenshot on the left hand side I have the authorisation heading above the general conditions of permit field. in this case the formatting is correct and within the borders.

    in the right hand side example the authorisation heading is placed below the same fields 'general conditions of permit' and 'I accept all terms and conditions' and this time the authorisation heading falls outside of the forms border.

    for my final form I will also have a signature field and payment widget however all of these always fall outside of the border.

    I hope this makes more sense. I have marked this information on my screenshot but am unable to attach a new screenshot.

     

     

  • Profile Image
    aytekin
    Answered on June 27, 2014 at 04:51 AM

    I see the same problem on my browser as well. I am on Chrome + Apple OS X. 

     

    I think the problem is happening because of hidden fields and conditions. I am sending it to a developer who can investigate the problem. 

     

  • Profile Image
    egeg
    Answered on June 27, 2014 at 05:49 AM

    Hi there,

    I found the source of the problem. This has to be an incredibly rare bug that happens with the Text field.

    Here's a clone of your form with the problem fixed: 
    http://form.jotformpro.com/form/41772550425958

    If you don't want to clone your form, the problem is caused by the "GENERAL CONDITIONS OF PERMIT" text field under the Custom Stands Form near the end.

    Open it as if you were editing the text, and click on the HTML button. 





    Now, the html editor should automatically fix the problem while opening it but just to make sure hit CTRL( or CMD) + F and search for </ul> . If it finds any matches, simply delete and click update.

     


    You problem should be fixed now.

    Please let us know if there's anything else we can do for you.

    Thanks.