Not receiving submissions, entries not going through

  • Profile Image
    couragerenewal
    Asked on June 30, 2014 at 02:19 PM

    I've been working on this form for several weeks now and we finally sent it to our network of 200 users after having extensively tested it. All of a sudden, submissions are not coming through at all. No notifications to me, no autoresponders to them, and no new submissions in my jotform inbox. WTH

  • Profile Image
    couragerenewal
    Answered on June 30, 2014 at 02:25 PM

    Worth noting: Last week test submission worked flawlessly. I just tested it on my end and everything went through fine. But two users have tried and their submissions did not go through.

  • Profile Image
    Mike_T
    Answered on June 30, 2014 at 02:44 PM

    Thank you for contacting us.

    I was able to submit your form:

    However, I have found one issue on the form. The '9. Sponsoring Organization (if any)' field is set to Email validation, so this might be a reason of unsuccessful submissions.

    If you users receive any errors or warnings, please let us know.

  • Profile Image
    couragerenewal
    Answered on June 30, 2014 at 02:49 PM

    Hi thank you.

    I successfully received a notification of your submission in my email and jotform submission box. Did you receive the autoreply notification on the email address you entered?

    This is very strange that some users have submitted successfully while others cannot.

    I also turned off the email validation on that question, thanks for catching it.

  • Profile Image
    Mike_T
    Answered on June 30, 2014 at 03:17 PM

    Yes, the email Autoresponder was successfully delivered to my temporary inbox.

    Also, I have found several links to surveymonkey on the form text field, so you may want to remove them.

    In case you do not want to receive the Autoresponders related to unfilled email fields, you can set them to be conditional.

    Example:

    Thank you.

  • Profile Image
    couragerenewal
    Answered on July 01, 2014 at 04:30 PM

    Turns out my problem was with our users, not the form itself. Thank you for your help investigating the problem and uncovering some other ways to optimize the form. I appreciate Jotform's prompt and thorough support!

  • Profile Image
    Mike_T
    Answered on July 01, 2014 at 04:45 PM

    You are quite welcome, and thank you for using our service! Please feel free to contact us anytime if you need any further assistance. We would love to help.