What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Bug - Calculation Widget does not carry over Price to Payment Integration when $ symbol is used

    Asked by okemeki on July 03, 2014 at 09:52 AM

     

    When I fill the form out and press Submit button preview mode,

    it just takes me to "Thank You" page.

    The last field showing on the form is the paypal tool.

     

    Page URL:
    http://form.jotform.co/form/41832094812857

    Screenshot
    does not work tool paypal tool preview fill and
  • Profile Image

    Answered by okemeki on July 03, 2014 at 10:09 AM

  • Profile Image
    JotForm Support

    Answered by KadeJM on July 03, 2014 at 11:50 AM

    I see this is a followup to your other 2 threads here and here which had no explanation. In the future we ask that you please do not open up multiple threads about the same issue. 

    Regarding your problem at hand I think this is happening because it's not configured correctly since the price for your AUD donation field isn't being carried over to it. Instead you are only seeing your resolution so your form calculation is incorrect.

    Are you trying to multiply the Photo Resolution times the initial price? Or? I think this needs to be simplified more, but just looking at what you have now is not really enough to go on. We need to understand the math you are intending to use since your current calculation seems to be doing the exact opposite. I will try to see if I can figure out a way to get this to work using your current setup.

     

    My Simple Calculated CarryOver Test (it works):

     

    Your Form (AUD shows 0):

     

  • Profile Image
    JotForm Support

    Answered by KadeJM on July 03, 2014 at 12:03 PM

    Turns out we found the issue and double-checked it just to be sure.  It's the " $ " (dollar-sign) symbol which is breaking your calculation. The rest of your calculation is fine. It seems that our form calculation widget doesn't want to work with that even though I would think that it should. I've sent this over to our developers to get this problem fixed.

    Removed Dollar Sign:

     

    Now it's working:

     

  • Profile Image

    Answered by okemeki on July 03, 2014 at 08:02 PM

    Great, Thanks for your help.

     

    PS: Sorry for creating the 2 threads here and here.

          I did it to upload 3 screen shot images. As the forum editor did not allow

    me to upload multiple files.

  • Profile Image
    JotForm Support

    Answered by Welvin on July 03, 2014 at 10:22 PM

    You're welcome!

    You can actually upload multiple screenshots. Just please follow this guide: https://www.jotform.com/answers/277033.

    Thanks